[Solved] After a recent sysytem update Mega.nz Desktop no longer starts

Hi, as said in the title
A couple days ago after a heavy system updates MegaSync desktop has stopped working.

journalctl -b | grep mega
dic 20 10:36:00 TRIGKEY systemd-udevd[452]: /etc/udev/rules.d/99-megasync-udev.rules:1 The line has no effect, ignoring.
dic 20 10:36:19 TRIGKEY megasync.desktop[1754]: /usr/bin/megasync: error while loading shared libraries: libicuuc.so.73: cannot open shared object file: No such file or directory

Can anyone help me how to restore the situation ?

Install the aur package, it will rebuild against the new ICU (v74) libraries.

A similar situation :thinking:

No changes :face_with_raised_eyebrow:

I had this problem too, so I uninstalled it, then installed the megasync-nopdfium version from AUR. It now works perfectly with Plasma on X11.

Did you cleanbuild?

How to do it right?

:: There are 3 providers available for libpdfium:
:: Repository AUR
    1) libpdfium-nojs 2) pdfium-binaries 3) pdfium-binaries-v8 

Enter a number (default=1): 
==> 
AUR Explicit (1): megasync-4.11.0.0-1
AUR Dependency (1): libpdfium-nojs-6045.r1.2e2cfb0399-1
Sync Dependency (4): crypto++-8.9.0-1, freeimage-3.18.0-21, libmediainfo-23.11-1, libzen-0.4.41-1
Sync Make Dependency (1): swig-4.1.1-2
:: (1/2) Downloaded PKGBUILD: libpdfium-nojs
:: (2/2) Downloaded PKGBUILD: megasync
  2 megasync                         (Build Files Exist)
  1 libpdfium-nojs                   (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 

I don’t have the first three lines. Megasync is simply installed without any questions

Edit: I chose whatever the defaults were as I installed it.

I used pacseek and installed it from there.

Up and running with no issues.

The only one I could get to work for me is the megasync-nopdfium version from AUR. There seem to be issues with the plain megasync version in the AUR and the Bin version is out of date.

I just typed:

yay -S megasync
AUR Explicit (1): megasync-4.11.0.0-1
:: PKGBUILD up to date, skipping download: megasync
  1 megasync                         (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 

Pressed “A” to cleanbuild all and everything is working here.

Rock n roll :+1: :smiley:

After the command yay -S megasync, megasync is simply installed without any questions :thinking:

Yes, the version megasync-nopdfium works :+1:

Happy days :smiley: :v:

1 Like

I tried to install yay -S megasync-nopdium as suggested, however the installation does not work and gives “Error Installing Repo Packages”. Error without any other indications.
yay -S megasync reinstal the version already present in the system (4.11.0-3) without any benefit

I solved the installation error of megasync-nopdium. Now the desktop works again

2 Likes

Ahh good. :+1: :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.