Solution to fix dual boot problem on dual SSDs setup

This post is a follow-up on my previous post a couple weeks ago. I just want to share the solution with anyone who has the same problem. There’s NO need to re-installed Windows 10. You just need to rebuild the EFI partition on the Windows 10 SSD. Please see my original post link, the rebuild instruction link and Chris’ YouTube tutorial link below. I performed it on my other dual SSDs laptop with success.

I really don’t know why Linux Mint wants to EAT(delete) the Windows 10 EFI partition, doesn’t make sense at all.

[Dual boot on two separate SSDs]

Win10 EFI Rebuild Instruction

Chris’s EFI Rebuild video

If that is what is really happening, I think the Linux Mint’s developers would appreciate to know about it.
They will then have a chance to look at it and fix the issue.

Have you considered to file a report?

Definitely agree with previous comment. Mint had a great team, and has been a long running stable project for years. They want to be a first choice for Linux. They definitely need to know as many first time users choose to dual boot.

1 Like

Will definitely do it!

Is it possible if you can help me with my other post? It’s been up for a couple days but haven’t seen any reply yet, probably no solution. Thanks a lot!

Dolphin freezes when launching VPN

1 Like

I’m sure they are going to appreciate it.

I saw your other thread the other day. Unfortunately I have no idea what might cause the issue.

You could perhaps wait a bit more and the bump the thread. Hopefully someone will come along and helping you out.

1 Like

I tried using the Medicat USB (esayUEFI and rescatux) to rebuild it but both failed. Had to manually created the EFI partition. If anyone does use Medicat USB successfully, please share.

1 Like

Maybe this article will help me solve the Dolphin freezing problem? Since those two options on the fstab has time out…but I don’t really understand what the options really mean…

what’s the difference between “x-systemd.device-timeout=10” vs “x-systemd.idle-timeout=1min”? If I want to limit Dolphin (or EOS) to attempt to mount the network drive for only 10 seconds. what’s the property way to set the switch?