Small tray icons on polybar

I am using polybar and find it great but there is on problem : the tray icons a very small compared to the bar. Here is a screenshot
Is there a way to fix that ?
Thank you for help.

; Dimension defined as pixel value (e.g. 35) or percentage (e.g. 50%),
; the percentage can optionally be extended with a pixel offset like so:
; 50%:-10, this will result in a width or height of 50% minus 10 pixels
width = 100%
height = 90

not sure as i do not use polybar i find it way to complicated to set up ;= )

In your config.ini add this:

; Scale factor for tray clients
tray-scale = 1.0

and adjust the value to your liking.

1 Like

Thanks @joekamprad and @anon13373109. Tried both solutions and the width/height only change the size of the bar and the tray-scale show blank space if the value is not 0.9, 1.0 or 1.1.

but does it scale the icons?

Yes, but they are not centered. It scales the icons container. Here are screenshots
Capture d’écran_2022-11-30_15-18-52 0.9
Capture d’écran_2022-11-30_15-18-40 1.0

h,mm looks similar to the issues with i3bar tray and scaling where it does not work in any way too…
But as i said i am not using polybar.

There should be a lot users here with better knowledge about it as me…

Well, thanks for those answers. Hopping that they will be helpfull to some people…

Not sure if this helps (as I’m using the i3 bar, not polybar, but the font/icon sizes are controlled within the i3 config file - not the bar specific config file. Perhaps that’s where you should search for ‘font’ related lines. I have mine set to 14 point which seems to work fairly well for my various setups.


Thanks, I tried, but it doesnt work…

as polybar is using iconic font for the icons shown in tray… could be an issue with the used font installed… there are so many different ones…

One other thought … I’ve had issues with icon appearance with certain other apps in the past and was able to resolve them by taking a careful look at my terminal emulator settings (in my case, detailed preferences within konsole).

You might have a look at whether your terminal is getting involved with how polybar interacts with your display. In my case, it came down to ensuring I had the right font and size selected. In yours, in might just be a matter of size?

have you tried tray-maxsize options in polybar config??

Yes, I tried

I tried different font and sizes, but it doesn’t solve the problem…

This is a bit of a long shot, but would you happen to be using a monospace font?