Slower broadband on endavorous

Hi, I am glad to be the part of this fantastic linux! I have dual boot with Windows 10.
On Windows 10 I got 180 Mbps download / 40mbps upload while on endeavouros linux I got max 20 Mbps download/ and about 4 Mbps upload. Ping are bit higher on linux than on windows.
Now the questions is how I can fix my broadband on linux? I even tried broadband via cable but speedtest are same and slower on my linux. Would be happy to hear any tips, recommendation which would fix my broadband.

Thanks

Your OS won’t affect your broadband connection - you should talk to your ISP if you have issues there.

Can you share the output of the command ip link

2 Likes

Here is an output: ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0f1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether 98:28:a6:1f:45:1d brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether 30:d1:6b:a3:e1:c5 brd ff:ff:ff:ff:ff:ff
5: vboxnet0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 0a:00:27:00:00:00 brd ff:ff:ff:ff:ff:ff
7: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 500
    link/none

Your wired adapter appears to be down. I would start by getting that working at speed before you try to troubleshoot wireless. If you can plug that in and it is still slow, please share:

sudo ethtool enp2s0f1
2 Likes

Its also worth removing other factors like VPN connections from the troubleshooting process.

2 Likes

That looks good. Disconnect from your wireless network and let us know what your speeds are and how you are testing.

Here is Speedtest: Will check evening again as on mobile I have about 70 Downloads now…

This test is not helpful:

If you are going to provide data please provide data that demonstrates the issue you’re actually having, not some other issue or an unrelated situation. A slow speed test while downloading a load of data (or your broadband connection is otherwise in use) is absolutely to be expected.

Again, if you suspect your broadband connection to have an issue then talk to your ISP as you are paying them for the service.

While I personally can’t help you, I do have one request that will help find the issue.

Can you post the results of inxi -Fxxz ? This will tell the people here trying to help you some important information. For example, what kernel you are using, what network adapter do you have, and what driver is being used. There have been issues in the past where certain kernels and drivers did not work well together. This can cause a difference in speed between Windows and Linux.

Hopefully this information will help further find and fix the issue you are having.

5 Likes

My old ThinkPad X1 Carbon constantly broke on the latest kernel. Either wifi or bluetooth - I don’t htink both ever worked at the exact same time on latest. 4.19 and 5.04 were always great though.

The package akm can help you if you don’t have any other kernels yet.

2 Likes

It’s start to be annoying. Now I have just 14 Mbps Download on linux and 190 MBPS on windows. Nobody download or use my broadband just me. Here is an output of: inxi -Fxxz

System:
  Kernel: 5.13.12-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 
  Desktop: Budgie 10.5.3 wm: budgie-wm dm: LightDM, LXDM 
  Distro: EndeavourOS base: Arch Linux

Edited:

Open the welcome app. There is a button for removing r8168. Click it and let it run then reboot and test again.

2 Likes

Indeed.

Are you using wifi or an Ethernet cable, as earlier suggested? What about the VPN?

You were asked for this:

and yet you did this:

and removed all the useful information.

If you want help then you have to give information people ask for. “It doesn’t work” doesn’t work.

However, the information is thankfully still available despite you trying to hide it:

Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8168 v: 8.049.02-NAPI 
  port: 3000 bus-ID: 02:00.1 chip-ID: 10ec:8168 
  IF: enp2s0f1 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network 
  Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 3000 
  bus-ID: 03:00.0 chip-ID: 168c:0042 
  IF: wlan0 state: up mac: <filter> 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full 
  mac: N/A 
  IF-ID-2: vboxnet0 state: down mac: <filter> 

This shows that you are using a VPN over wifi, two things that we specifically requested that you remove as variables by 1) using an Ethernet cable and 2) not using a VPN.

If you think this might be related to your wifi (rather than the broadband connection itself) then you can also search for the wifi chipset and driver for threads that may contain useful information.

1 Like

There is tun0 which is VPN connection, we mentioned it before. It’s works now. I just simply changed from UDP to TCP and connect to VPN via openvpn with no client which I was used and downloaded from aur before. I apologise for the confusion, I have messed things up a bit but finally it works. Thank you for your help.