Slow, unstable Wi-Fi, trouble connecting to 5Ghz

I’m running Endeavour with KDE. I’m using a Archer T2U Plus dongle to connect to my Wi-Fi network. I have experienced unreliable connections since long ago. Observable behaviour:

  • 2.4Ghz: very slow speeds, connection periodically drops, then reconnects
  • 5Ghz: network does not show most of the time. When it does, computer rarely connects. Most of the time it won’t connect at all and bounce back to 2.4Ghz, sometimes not even that and I have to reboot to get it to reconnect to a network.
  • I have a Windows partition. These behaviours are not reproducible on Windows (e.g. 5Ghz shows on boot, can easily connect with a stable connection)

I have done some basic troubleshooting:

Hardware information is found here. Boot log is found here. Partition info:

095211

I appreciate any help on this.

1 Like

A user on the AUR website suggests to use rtl88xxau-aircrack-dkms-git

See:
https://aur.archlinux.org/packages/rtl8812au-dkms-git

and

https://aur.archlinux.org/packages/rtl88xxau-aircrack-dkms-git

There seem to be a couple different versions of this driver in the AUR. Should be installable via yay

Symptoms remain unchanged after trying both drivers.

  • rtl88au-dkms-git: 2.4Ghz remains slow, 1/10th of my network speed. 5Ghz does not show at boot. Once it showed, I’m prompted for the password, which rejects despite being correct.
  • rtl88xxau-aircrack-dkms-git: unusable. No connection to either network. Interface became unresponsive after a few minutes.

I have reverted back to the original driver, which gave me the best performance. Additional observation: when connecting to a network, it takes 40 seconds or more to configure interface (Message: “Configuring interface…”) before establishing or dropping connection.

As an additional test, I have a ThinkPad T480 with a fresher Endeavour install. Its able to connect to both networks after boot, easily switching between them with a stable connection.

Did you use the same Archer dongle on the Think Pad and which OS is running on it? If Linux, is the same driver installed?

Welcome, @olaolson ! :enos: :enos_flag:

Yet your hardware info doesn’t say anything about that dongle.
Instead, a built in wifi chip is enabled and running?

Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168
IF: enp5s0 state: down mac:
IF-ID-1: wlan0 state: up mac:

Did you use the same Archer dongle on the Think Pad and which OS is running on it? If Linux, is the same driver installed?

No, I used the built-in Wi-Fi receiver, as a test of reception. As mentioned above, it’s running Endeavour too. I can conduct the experiment of trying the dongle on it and reporting back.

Yet your hardware info doesn’t say anything about that dongle.
Instead, a built in wifi chip is enabled and running?

The motherboard has no built-in Wi-Fi receiver. https://www.gigabyte.com/Motherboard/B450M-DS3H-rev-1x/sp

I tried to google what chipset is used in the dongle. According to this:

It is a rtl8812au chip set. Whereas your driver is for 8821/8811. I don’t know how significant is the difference though.

There are a couple options in the AUR still with different versions of the rtl8812au driver.

See:
https://aur.archlinux.org/packages?O=0&SeB=nd&K=rtl8812&outdated=&SB=p&SO=d&PP=50&submit=Go

You could try them. Besides trying different drivers I don’t really see what else you could do as tp link doesn’t seem to supply Linux support officially.

The information on that link is incorrect. It is a RTL8821au chipset. The output of lsusb confirms it:

Bus 001 Device 009: ID 2357:0120 TP-Link Archer T2U PLUS [RTL8821AU]

I did the experiment with my ThinkPad. I disabled the internal Wi-Fi receiver and tested the dongle on it. Both morrownr’s driver and rtl8821au-dkms-git package from AUR yielded good results. Therefore, I do not believe it’s a driver issue, but rather a misconfiguration somewhere in my desktop computer. The problem hasn’t always been present, and the dongle has worked without a hitch before.

If I can’t find any solutions, I will opt to re-install the whole OS.

Okay. Could you try a different USB port?

Edit: The current version of the lts-kernel is 6.1.35. Did you update it to this version inbetween and did it affect the WiFi performance?

I already tried using a different port. Before opening the thread, I moved the dongle from the back ports to the front ones, to rule out reception problems.

I have updated the lts-kernel a couple of times over the last weeks but I have not noticed any difference.

The last thing that comes to my mind is switching to the standard kernel and see if it changes the behaviour.

I have fixed the issue. On the Github for the aircrack driver, it suggests to have NetworkManager set a fixed MAC address. Checking the Arch Linux wiki:

Note: Disabling MAC address randomization may be needed to get (stable) link connection and/or networks that restrict devices based on their MAC Address or have a limit network capacity.

I turned off MAC randomization for NetworkManager. I have a stable connection on both 2.4Ghz and 5Ghz networks consistently after rebooting several times, the latter network showing right after boot. Strangely enough, my network does not have filtering enabled. This wasn’t an issue on the ThinkPad with the dongle. Whatever the reason may be, it doesn’t warrant further investigation, I’m satisfied now.

Thank you all for your help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.