Slow boot - wait-online

systemd-networkd-wait-online.service adds 2 minutes to my boot, I’ve tried disabling this but it doesn’t help. Or perhaps I’m not disabling it? I’m bad a troubleshooting. How can I get rid of this delay? My boot time should be like 20 seconds, and I’m pretty frustrated with it. I’ve tried googling some answers but no one seems to have the same problem.

You could disable a service with:

sudo systemctl disable XXX.service

where XXX is the name of the service. You might add --now to both disable and stop it in the current session as well.

Also you could have a look at:

systemd-analayze blame
systemd-analyze critical-chain

I already used analyze-blame and critical chain to determine it’s systemd-networkd-wait-online.service that’s the culprit. But disabling the service doesn’t seem to do anything, hence my post.

Thank you.

You need to reboot after disabling it.

Does this mean that it still starts and is running on your system?

Another alternative would be to mask it: see man systemctl

well darn, I did it again and now it’s disabled. It is a mystery.

Life is! :sweat_smile:

Yes, previously I’ve tried sudo systemctl disable systemd-networkd-wait-online.service and rebooted and it didn’t disable. This time it did. I can’t imagine what I did differently.

1 Like

What are you getting now after reboot:



I’m sure the problem is pebcak :wink: I know enough to get in trouble, but not enough to fix it. Anyway, thanks for answering me. Not having it wait for the network has broken my remote shares getting mounted on boot but I’ll try to fix that myself

-analyze reports

startup finished in 10.576s (firmware) + 2.322s (loader) + 2.766s (kernel) + 1.735s (userspace) = 17.401s reached after 1.493s in userspace

These times seem quite reasonable.

Well then, there we have it.

If I am not mistaken, you could modify a service to start later. In this case, if you don’t need the shares to be mounted immediately at boot you could put in some delay. Do some research on how to delay a systemd service.

1 Like

only for comparison, my report:

Startup finished in 2.052s (firmware) + 7.818s (loader) + 1.275s (kernel) + 1.113s (userspace) = 12.260s reached after 1.095s in userspace

1 Like

Yeah after disabling the service my boot time was lickety split the way god intended. Thank you for your time!

1 Like