Slow Boot up

the output of

systemd-analyze critical-chain

is :

graphical.target @40.867s
└─sddm.service @40.867s
  └─plymouth-quit.service @40.741s +108ms
    └─systemd-user-sessions.service @40.650s +56ms
      └─network.target @40.622s
        └─wpa_supplicant.service @39.347s +1.274s
          └─basic.target @30.923s
            └─dbus-broker.service @29.488s +1.431s
              └─dbus.socket @29.408s
                └─sysinit.target @29.367s
                  └─systemd-update-done.service @29.290s +76ms
                    └─ldconfig.service @22.810s +6.443s
                      └─local-fs.target @22.748s
                        └─boot-efi.mount @22.230s +517ms
                          └─systemd-fsck@dev-disk-by\x2duuid-E055\x2d27B8.service @19.309s +2.874s
                            └─dev-disk-by\x2duuid-E055\x2d27B8.device @584542y 2w 2d 20h 1min 47.217s +21.643s

and the output of

systemd-analyze blame

is
blame.odt (54.1 KB)

would you help me for it?

Looks like it is running fsck on your EFI partition? Does that happen every boot? Are you dual-booting?

1 Like

yes dual boot with windows 10
and I don’t know what is fsck.

man fsck

Make sure that you have “fast startup” disabled in Windows settings. Otherwise your disks will be not be properly closed on shutdown.

It is filesystem checking and repair.

1 Like

checking my win10 and yes fast startup was on.
turn that off and I think it had little effect.
this is output of systemd-analyze after that:

systemd-analyze critical-chain:

graphical.target @35.910s
└─sddm.service @35.910s
  └─plymouth-quit.service @35.791s +95ms
    └─systemd-user-sessions.service @35.653s +117ms
      └─network.target @35.627s
        └─wpa_supplicant.service @34.454s +1.172s
          └─basic.target @25.420s
            └─dbus-broker.service @23.921s +1.496s
              └─dbus.socket @23.820s
                └─sysinit.target @23.765s
                  └─systemd-resolved.service @23.144s +620ms
                    └─systemd-tmpfiles-setup.service @21.242s +1.837s
                      └─local-fs.target @21.091s
                        └─boot-efi.mount @20.810s +278ms
                          └─systemd-fsck@dev-disk-by\x2duuid-E055\x2d27B8.service @18.007s +2.756s
                            └─dev-disk-by\x2duuid-E055\x2d27B8.device @584542y 2w 2d 20h 1min 47.091s +20.440s

systemd-analyze blame :

blame.odt (56.7 KB)

bump

It looks like it is having trouble mounting your EFI partition. You might check the journal and see if there is anything interesting there.

can I send it here?
If yes please tell me the right command.