Skype won't launch after power outage

i have skypeforlinux-stable-bin package installed, i had left my pc with skype open, and then there was a power outage, when i got back i turned on pc and it wound’t boot, to fix this i had to boot the live CD and run sudo fsck -f /dev/sda2, now as for skype it won’t launch anylonger, already tried reinstalling it, here’s the terminal output:

[ramon@ramon-m61pmes2p ~]$ /usr/share/applications/skypeforlinux.desktop 
bash: /usr/share/applications/skypeforlinux.desktop: Permissão negada

Did you also happen to try removing, then reinstalling?

Desktop launchers may or may not be intended to be executed from the command line. It appears this one is not, therefore it is not marked as executable, therefore it will not execute. Therefore, this is inconclusive.

Can you provide any other information, e.g. run the Skype executable itself rather than the desktop launcher?

that’s the skype executable.

It’s not - open that file in a text editor and you’ll see the executable on the Exec line. You can also find the files the package installs via e.g. pacman -Ql skypeforlinux-stable-bin.

Also, you didn’t answer my other question, which might end up being something easier to try than digging through the filesystem.

i took a look in my applications folder and found this:
Exec=/usr/bin/skypeforlinux %U
tried running this on the terminal and here’s the output:

[ramon@ramon-m61pmes2p ~]$ LANG=C Exec=/usr/bin/skypeforlinux %U
bash: fg: %U: trabalho não existe

Are you reading the output and trying to work out what it’s telling you?

The executable is


so run that.

Also, please do answer my earlier question about trying to remove and reinstall the application, which, if it fixes any files corrupted by a hard power-off, will be a far easier option.

yes i already tried reinstalling the package like 5x or so

That doesn’t preclude removing the package first, but sure, let’s say that it doesn’t make any difference.

i ran Exec=/usr/bin/skypeforlinux and nothing happened, it’s like the package got corrupted or something like this

Why would you do that?

I’ve already provided the command - in full - that you can copy and paste if you want to:

same thing, no output

No output normally means it’s running.

Is is running in the background already? Have you rebooted, or run something like ps ux to check?

if i just try to drag and drop skype’s icon into the terminal it shows permission denied, if i run it as sudo it shows me “command not found”

i do have KSysGuard, not sure if it’s the same, i’ll try to reboot and let you know

i reebooted and ran the command, skype doesn’t show up

try these steps

  1. uninstall skype
  2. manually deleting any leftovers:
  • ~/.config/skypeforlinux/
  • /usr/share/skypeforlinux/
  1. install an alternative package like skypeforlinux-preview-bin from aur. This should force uninstall of the old package.
    If the alternative package can be installed and runs ok, you can then reinstall skypeforlinux-stable-bin which in turn will remove the skypeforlinux-preview-bin
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.