Since 5.21 there are glitches or something like that on my screen

Not sure…
Give us your:

inxi -Fxxxz

Also, what’s your display scaling set to in Plasma settings?

System:
  Kernel: 5.10.16-hardened1-1-hardened x86_64 bits: 64 compiler: gcc 
  v: 10.2.1 Desktop: KDE Plasma 5.21.0 tk: Qt 5.15.2 wm: kwin_x11 
  dm: SDDM Distro: EndeavourOS base: Arch Linux 
Machine:
  Type: Desktop Mobo: ASRock model: H110M-HDS serial: <filter> 
  UEFI [Legacy]: American Megatrends v: P7.50 date: 01/20/2018 
CPU:
  Info: Dual Core model: Intel Core i3-6100 bits: 64 type: MT MCP 
  arch: Skylake-S rev: 3 L2 cache: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 29608 
  Speed: 800 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
Graphics:
  Device-1: Intel HD Graphics 530 vendor: ASRock driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1912 class ID: 0300 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: intel unloaded: fbdev,modesetting,vesa 
  resolution: 1920x1080~60Hz s-dpi: 96 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASRock 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
  class ID: 0403 
  Sound Server: ALSA v: k5.10.16-hardened1-1-hardened 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  chip ID: 10ec:8168 class ID: 0200 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 223.57 GiB used: 98.44 GiB (44.0%) 
  ID-1: /dev/sda vendor: A-Data model: SP550 size: 223.57 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 0AA 
Partition:
  ID-1: / size: 219.06 GiB used: 98.44 GiB (44.9%) fs: ext4 
  dev: /dev/sda1 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 37.5 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 165 Uptime: 1m wakeups: 0 Memory: 7.48 GiB 
  used: 1.41 GiB (18.8%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  Packages: pacman: 1087 Shell: Bash v: 5.1.4 running in: konsole 
  inxi: 3.3.00

I have nothing changed in Plasma Display scaling. Set to 100% as normal.

Have to admit that this glitch is showing up on desktop screen with eos-welcome. So it isn’t the browsers Fault right?

When i scroll down and up in the browser, the font is pixelating or however you call this “feature”.

1 Like

Indeed, looks more like driver / graphical problem.
As far as i understand this is PC and it have only Intel (CPU) video, correct?


I’ve noticed you’re using hardened Kernel - that may be very well the reason, can you please try LTS Kernel + reboot to see if issue is gone?

Yes just a desktop pc with an onboard GPU (Intel graphics).

The problem shows up even with linux-lts.

1 Like

@dalto @jonathon @joekamprad
Any ideas?
Intel / Mesa / X11…?

Shouldn’t be Plasma, otherwise everyone would see that

Have you tried creating creating

/etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "AccelMethod"  "uxa"
        Option      "DRI" "False"
EndSection

Or

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   #Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true" 
   Option      "DRI"    "3" 
EndSection

Edit: https://wiki.archlinux.org/index.php/intel_graphics#Xorg_configuration

2 Likes

i’m not a Plasma user, but just for fun, you could play around with the compositor settings. → systemsettings → use the search → search for “compositor”

@ricklinux: Now it’s the second time that my onboard graphics is making trouble again. First attempt with first entry works. But i don’t understand why it works one day and another day it’s broken?!

@T-Flips: Hey, thank you. I tried already to improve my glitch with this settings, but it didn’t work.

Did you have that file or did you have to create it? If it wasn’t there before then i can see possibly issues as different updates may have contributed to it and it may be intermittent also? Hopefully this fixes it.

1 Like

I Had to create it.

1 Like

Help me please. The glitch is back and i already added both versions from @ricklinux post.

This time the backgroundd image breaks through the opened windows like terminal or browser windowss.

Have you tried wayland on kde? just install plasma-wayland-session and then restart and log in under wayland instead of x11 at the bottom left of the screen. You could try this and see if wayland works better.
On my system it is the best I’ve seen it working yet.

No i didnt try wayland yet. But my system is so broken, that i even cant use terminal or something else. Re install?

It’s on KDE and you had it working okay. What happened?

@Endlich
Maybe look at kwin-lowlatency package in the AUR. Don’t know much about it or whether it will work.

@ricklinux I made some updates. But i don’t know which exactly and after that it started to fail on my desktop. I couldn’t use terminal, because i can’t see what i was typing into it. Videos freezed in firefox and the fullscreen mode was buggy, so videos was shown buggy. There were a lot of heavy malfunction with my graphics, so the screen was teared away and replaced with my background image, i had to re-install my endeavouros and it’s gone for now.

Did you reinstall the same desktop KDE?

Yes, i had to. It’s as far as i know the only one DE which fits me. But i had to improve already KDE with your 20-intel.conf trick. But since then there are no further errors.

It’s working very well for me on Ryzen hardware with AMD Graphics both on X11 and Wayland.

I guess next time i take an amd computer.