Shutdown hangs at stop job for Simple Desktop Display Manager

When running the poweroff, reboot or systemctl [poweroff/reboot] -i commands my shutdown starts hanging at ´[***] A stop job is running for Simple Desktop Display Manager ([x]s / no limit) and will unless force my laptop to turn itself off, often hang for well over 100 seconds.

This issue seems to be exclusively for Plasma on Wayland, as I did not have this issue when I was using X11 (tests done before testing confirms this). I am unsure whether or not this is a bug in Wayland or if it’s me who has set up something wrong. If it is the ladder, I wont be able to point to what as I have only been toying around with KDE customization in the system settings and have not changed any scripts.

My shutdown time on X11 is probably under 10 seconds, and I would really like it if I could make Wayland act the same. It is currently not an option for me to use X11 on a daily as I’m fully dependant on touchpad gestures.

Thanks in advance for all the help!

Neofetch dump:

                   ./sssso-                ----------------- 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: 20X2S0DL00 ThinkPad L14 Gen 2 
             `-/ossssssssssssso/.          Kernel: 6.1.12-arch1-1 
           `-/+sssssssssssssssso+:`        Uptime: 2 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 1121 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: bash 5.1.16 
      .://+ssssssssssssssssssssssso++:     Resolution: 1920x1080 
    .:///ossssssssssssssssssssssssso++:    DE: Plasma 5.27.1 
  `:////ssssssssssssssssssssssssssso+++.   WM: kwin 
`-////+ssssssssssssssssssssssssssso++++-   WM Theme: Breeze 
 `..-+oosssssssssssssssssssssssso+++++/`   Theme: [Plasma], Breeze [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Icons: Papirus-Dark [Plasma], Papirus-Dark [GTK2/3] 
  `:::::::::::::::::::::::::------``       Terminal: konsole 
                                           CPU: 11th Gen Intel i3-1115G4 (4) @ 4.100GHz 
                                           GPU: Intel Tiger Lake-LP GT2 [UHD Graphics G4] 
                                           Memory: 2311MiB / 7600MiB 
[runarcn@endeavour ~]$ echo $XDG_SESSION_TYPE 

This issue is a user space (at user level) one, so you can check the modified settings in KDE System Settings (there is an option to show changed settings). It is not a system level issue.

Try to get relevant error messages in the journal, or using standard command:

systemctl poweroff

For -i to act as intended (bypass checks), you need sudo/root/admin privileges, so try with sudo.

sudo systemctl -i poweroff 
1 Like

For wayland, you should switch to sddm-git (yay -S sddm-git) which will remove sddm and install the sddm-git package. (I also did that some weeks ago, no negative consequences so far)

There are essential commits in the git version that are not yet in the release version, and it does not look like we will see an update any time soon
Recent “discussion” can be found here: SDDM takes time to close when rebooting/shutting down - #2 by BS86


This seems to have solved it. Thank you very much!

For anyone discovering this thread in the future:

yay will suggest that you do not remove sddm and replace it with sddm-git after the install should you go with this solution. This is okay, and you can take a backup of your system should you want to be completely sure. If at any point you change your mind you can also reinstall sddm via pacman -S sddm

If you do not want to install sddm-git you can also log out before shutting down / rebooting. You can then shut down / reboot from the login screen without SDDM hanging.

Another workaround is reducing the timeout until systemd kills the hanging process.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.