Serious help

hello yet again
i have quite the serious problem
i like to preface this that i do not want to mock kde and plasma
however, i tried to use plasma its not my thing
it has now essentially locked me into plasma
removing plasma breaks whatever other DE i tried (xfce and cinnamon)

id like to inquire how i can delete plasma without it totally breaking my system

Could reinstalling the system with your preferred DE be an option? Personally I should think that that would be a leaner and cleaner way.

id like to avoid such a thing as much as possible
frankly, plasma shouldnt have the power and possibilities to lock me in that much, a problem i never had before when switching to other DEs

Alright. Please wait then for a more informed suggestion. I just do one DE at a time so I am not well positioned to give any advice on what to remove and what not.

thank you
and thats the thing
usually you remove a DE the same way you install it
but for one reason or another plasma managed to totally lock me in, removing plasma always causes a blackscreen on boot, no matter the DE
and letting it be installed and trying to switch a DE plasmas greeter wont display a de properly

1 Like

I suppose that removing plasma will remove its display manager as well. Perhaps you need another Displayer Manager then. LightDm might be a good candidate.

But as said I have next to no experience to have several DE installed so …

when you install the DE properly the display manager is also installed (i checked several times when i tried), same results

Yes. I might be wrong but I think only one of them are enabled at the same time. I am not sure. You might want to check that up.

systemctl status lightdm

systemctl status ssdm

How do you remove the DE? Using the -Rsu option with pacman and also installing a display manager may do the trick. Preferably run the below on a TTY (which you can reach through Ctrl Alt F2 or Ctrl Alt Fn F2):

sudo pacman -S gnome
sudo pacman -S lightdm
sudo systemctl disable sddm.service
sudo systemctl enable lightdm.service
sudo pacman -Rsu plasma && reboot

Assuming you installed plasma earlier (replace it with whichever package/meta package that you installed for KDE)

Also assuming you want to try gnome. Refer to the Arch Wiki for your favorite Desktop Environment for which packages to install…

sadly this not helped, and no i am not using gnome, cinnamon or xfce
right now, even after trying what you wrote here i have the same graphical problems, im fairly certain are a bit worse now

as of right now im trying to get xfce to work again
i cant even try to logout and go to cinnamon due to how screwed up xfce is

As mentioned earlier, In my opinion, having installed several DE side by side is a recipe for trouble. It makes troubleshooting a bit complex.

I reiterate my suggestion: in order to save your time and energy, backup your personal data from your home folder and clean-install the system with your preferred DE.

Whatever you choose to do, I wish you “Bonne Route” !

1 Like

i managed to at least remove xfce now so i am able to use my system again via cinnamon

so for now i will have to stay on cinnamon (not a problem since i like cinnamon)

thanks again pebcak but that is not an option id like to consider

Did you look at our wiki?

There’s info about adding and removing desktops. Hopefully that helps.

Anyway, to be on the safe side, before making changes make sure you have a good and working backup of all of your personal data and files.


i tried removing xfce as it was described and installing it as well (tho it wasnt listed in the DEs) i used xfce4 and xfce4-goodies
but i had the same results, well almost, it did remember a theme that was set a long while ago, but xfce had otherwise the same problems

So that goal is to use Cinnamon and completely remove plasma? Or something else?

Do you mind me asking why you’re so afraid of a fresh install? It’s probably a while lot easier than what you’re trying to accomplish. To be honest if @manuel link to the wiki doesn’t help, it’s really your best option

Two more questions:

How did you install it in EOS? Did you use calamares?

And two please post up your inxi -Fxxxza --no-host

1 Like
1 Like

i used cinnamon
i used xfce at some point with this install as well
than i tried plasma and it screwed nearly everything up
so i was forced by plasma screwing up my entire system to go back to cinnamon

i am not afraid, i just consider going through my system and backup the necessary programs more tedious

im not sure what you mean, unless calamares somehow can be reused after installing your system to install more DEs, i used pacman

and thanks joe but manuel was faster

edit: i also think i shouldnt have to reinstall an entire system only because a single DE seems to have the capability to nearly destroy said install

Ok. Same question. What are you trying to accomplish? Where are you going if not Cinnamon?

What programs do you need to backup? @Kresimir had posted and others have posted you can save your programs to a text file and upon reinstall it’s like one command and you’re done.

I ask because it feels like you installed Arch properly, or tried to and don’t want to do the work again and are asking for help here instead of at Arch.

Please post your inxi I just want to make sure we’re looking to help with what you actually have and get you to where you’re trying to go.

i originally installed EOS with cinnamon, no problem
than i at some point installed xfce, no problem
than i wanted to try plasma yesterday and it made xfce unusable, so i am back to the original, which in itself isnt a problem of course, even after deleting plasma the recommended way, it left lasting visual damage to xfce so i uninstalled it

sorry i just didnt express myself properly, its less about the programs but their data

i never had managed to install vanilla arch and i very much am not inclined to try again, its imo one of not the most infuriatingly tedious and needlessly complex things i have done since i started using linux

  Kernel: 5.12.9-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux 
  root=UUID=69a5b5f2-e9c7-46d1-8dcb-c94c2c4a6c3e rw nvidia.drm.modeset=1 
  loglevel=3 nowatchdog quiet resume=UUID***** 
  Desktop: Cinnamon 5.0.2 tk: GTK 3.24.29 vt: 7 
  dm: GDM 40.0, LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux 
  Type: Desktop System: LENOVO product: 90HU002QGE v: ideacentre 510-15ICB 
  serial: <filter> Chassis: type: 3 serial: <filter> 
  Mobo: LENOVO model: 36EB v: SDK0J40700 WIN 3258014029993 serial: <filter> 
  UEFI: LENOVO v: O3QKT16A date: 11/06/2018 
  Info: 6-Core model: Intel Core i5-8400 bits: 64 type: MCP arch: Kaby Lake 
  note: check family: 6 model-id: 9E (158) stepping: A (10) microcode: DE 
  cache: L2: 9 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 33613 
  Speed: 1352 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 1352 2: 1287 
  3: 1547 4: 2587 5: 1014 6: 3896 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:3e92 class-ID: 0380 
  Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Micro-Star MSI 
  driver: nvidia v: 465.31 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1c82 class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 driver: loaded: nvidia display-ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 6400x1869 s-dpi: 96 s-size: 1693x495mm (66.7x19.5") 
  s-diag: 1764mm (69.4") 
  Monitor-1: DVI-D-0 res: 2560x1440 hz: 60 dpi: 93 
  size: 698x393mm (27.5x15.5") diag: 801mm (31.5") 
  Monitor-2: HDMI-0 res: 1920x1080 hz: 60 dpi: 70 
  size: 698x392mm (27.5x15.4") diag: 801mm (31.5") 
  Monitor-3: DP-1 res: 1920x1080 hz: 60 dpi: 94 
  size: 521x293mm (20.5x11.5") diag: 598mm (23.5") 
  OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2 
  v: 4.6.0 NVIDIA 465.31 direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 
  chip-ID: 8086:a348 class-ID: 0403 
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fb9 
  class-ID: 0403 
  Device-3: ELMCU RF Controller type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-8:4 chip-ID: 0c40:7a1c 
  class-ID: 0300 
  Sound Server-1: ALSA v: k5.12.9-arch1-1 running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.29 running: no 
  Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel 
  port: efa0 bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi 
  v: kernel port: 3000 bus-ID: 02:00.0 chip-ID: 8086:3166 class-ID: 0280 
  IF: wlan0 state: down mac: <filter> 
  IF-ID-1: virbr0 state: down mac: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb 
  v: 0.8 bus-ID: 1-14:6 chip-ID: 8087:0a2a class-ID: e001 
  Report: bt-service: disabled note: bt-adapter can't run. 
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 
  port: 4060 bus-ID: 00:17.0 chip-ID: 8086.2822 rev: 10 class-ID: 0104 
  Local Storage: total: 1.94 TiB used: 1.7 TiB (87.7%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD9SB8W128G1001 
  size: 119.24 GiB block-size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 4001 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SDSSDH3 1T00 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 00RL scheme: MBR 
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk 
  model: Extreme Portable SSD size: 931.51 GiB block-size: physical: 4096 B 
  logical: 512 B rotation: SSD serial: <filter> rev: 1012 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw-size: 118.95 GiB size: 116.58 GiB (98.01%) 
  used: 100.18 GiB (85.9%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 49.0 C mobo: N/A gpu: nvidia temp: 49 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 29% 
  Processes: 274 Uptime: 3h 11m wakeups: 0 Memory: 23.35 GiB 
  used: 9.39 GiB (40.2%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 11.1.0 Packages: 1589 apt: 1 pacman: 1588 lib: 448 Shell: Bash 
  v: 5.1.8 running-in: gnome-terminal inxi: 3.3.03 

The program data ( browser profiles, configurations etc.) are stored under your home directory.
If you have done some system-wide changes (like for example adding extra repos to pacman, etc.) then they are to be found under /etc.