Screenshot/recorder is good, but

This built-in feature of Gnome 42 is a convenient, but IMHO it’s only half a solution without annotation on the fly.

In case you are not using all the features Introducing GNOME 42 - YouTube

Is there something else, or will I have to stay with my trusted old Monosnap chrome extension for now?

1 Like

Flameshot

4 Likes

Thanks. Exactly what I need, great markup tools :partying_face:

It’s not running on Wayland, so I switched to Gnome on Xorg and it works well.
As an aside what would be the downside to using Xorg rather than Wayland? So far I don’t see any problems with other packages. I am happy at least flameshot works, so I can get on with my work.

It works on Wayland as well.

Make sure you got:

https://archlinux.org/packages/extra/x86_64/xorg-xwayland/

Don’t know if a reboot is needed but won’t hurt :blush:

1 Like

Yep, I’m on 22.1.1.1 the latest :thinking:

Should I just stay with Gnome on Xorg, since eveything works?

Are you sure it is fully working? For me, multi-monitor and hotkey support is broken on Wayland.

xorg-xwayland does not let Flameshot work for me, but it works under a Gnome on Xorg session. I don’t have multi-monitor, but hotkey works.

Yes, for sure it should work under X11. Flameshot is one of the reasons I am using X11 still. I haven’t found anything that can match the speed of it’s workflow.

I haven’t tried it in mutli-monitor set-up. This is just on a laptop. Would the laptop screen + an external monitor work for testing?

Also

on the laptop.

These are wayland-related packages I have on this system:

wayland (1.19.0-1)
xorg-xwayland (21.1.2-1)
wayland-protocols (1.21-1)
qt5-wayland (5.15.2+kde+r48-1)

I recall having issues with another qt-app not launching under Wayland. Installing qt5-wayland solved it.
If I remember correctly, it was Keepassxc.

1 Like

The issue with shortcuts is if you launch it via a shortcut, the application hotkeys no longer function.

Yes. For me, it gets locked to a single monitor when using a hotkey to take a screenshot.

I have that installed.

There is an open issue for this:

2 Likes

Is that a custom shortcut?

I am going to hook up the laptop with a monitor an test. Be back later.

I see your xorg-wayland is 21.1.2-1
Mine is extra/xorg-xwayland 22.1.1-1 could be why Flameshot won’t work in Wayland? I see it in AUR, should I upgrade to it?

1 Like

This is from when it got installed the first time. The current version on my system matches that of yours.

Sorry about the confusion!

1 Like

You really want to get into the habit of using the AUR only when you need to (think: last resort option or for testing purposes). Don’t get me wrong I use the AUR quite a bit, mostly for testing the latest git packages for certain software that Github/Gitlab devs recommend using, but also for software that hasn’t yet been picked up by a TU. There’s plenty of other reasons of course to use the AUR in a beneficial way, but anyways.

Ask yourself if you really want to rely on an Xorg group package from the AUR just to use some markdown options on Flameshot is worth it or not. Remember Xorg has literally no security built-in to it, hence why Wayland is becoming the default for many distros, built with security focused in mind. It’s your system after all, but if Flameshot works on Xorg in Gnome just stick with Xorg that way.

This is not an ultimatum btw, just a recommendation which you can use or happily ignore, the choice is yours :wink:

3 Likes

As long as everything works in Xorg and Flameshot runs, then I am happy.

I rarely install AUR packages for the reasons you stated.

1 Like

At the moment, with the laptop screen and an external monitor, flameshot seems to be refusing to launch on any of them. Or I might be doing something wrong.

Me
:arrow_down:

image

1 Like

Here is what I get when loading with Wayland session
It snaps a screenshot and

I can’t get it to run on Wayland. It’s only running on xorg, which IMHO is not as secure.

I get that as well but clicking on share, it goes to this screen:

where I can actually use Flameshot. This is the way it has worked for me.

How did you launch Flameshot? I did

flameshot gui

And share worked for me too.
That’s awesome we can use it in Wayland.

Not from terminal. Just super key and type fl ( or fla etc.) and enter. You should be getting an icon in the bar.

Screenshot from 2022-05-09 00-32-53

1 Like