Screenbrightness changes only color, not real backlight intensity

When changing screen brightness in Deepin, only the screen color changes to black, but the backlight stays unchanged.

At startup, I can brifely see something like [FAILED] Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0

hello, @mateus

Welcome.

Can you also descripte your hardware model processor Gpu.

mayby also part of your journal.

Hi, thank you!

I have a Ryzen 3700U CPU with integrated Vega GPU. My laptop is the lenovo s145.

journal 0: https://pastebin.com/iVfPsTt8
journal -1 and -2 are too big for pastebin, im sorry

got a ryzon 5 with vega 8, but is a desktop…
my acer got a old amd with ati, got also a boot issue with screen backlight, i can get darker or lighter with it… since for me works is ok , since your laptop is more new then my laptop have to see

i think its you : https://www.reddit.com/r/linux4noobs/comments/el3fmz/is_there_any_way_to_run_deepin_desktop_on_ryzen/fdfffj3/

kde you dont have that issue ?

you might try https://bbs.archlinux.org/viewtopic.php?pid=1618651#p1618651

Yes, that’s me.
I have used openSUSE Tumbleweed KDE, Ubuntu GNOME and KDE (kubuntu repo), Manjaro KDE (broke after I downloaded deepin from arch), Pop!_OS with gnome.

All worked fine for screen brightness. Even EndeavourOS installer running from usb worked fine

I have tried both acpi_backlight=vendor and video.use_native_backlight=1. None of them worked. I guess I will just have to wait until new Deepin, hope they support newer hardware

Just a shot in the dark…but since you seem to be having success with KDE have you tried using deepin-kwin? If you do you will also need to instal system-settings. You may also want to explore what display manager those other distros are using as opposed to the installed endeavour deepin / the live installer.

1 Like

I’m sorry, but, how can I install these packages without connection? Couldn’t find them in AUR


we have a new menu to link users to system logs wiki now !

2 Likes