Screen recording/screenshot problems

Everytime I’d take a screenshot whether it be by flameshot, spectacle, or OBS-Studio, I always get this bug (external link download to MEGA)where it takes a screenshot of the desktop, or another window present. What should be done to fix this?

~ » neofetch                                                                                                                                                              mika@Luna
                     ./o.                  mika@Luna 
                   ./sssso-                --------- 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: Aspire A514-53 V1.16 
             `-/ossssssssssssso/.          Kernel: 5.16.4-arch1-1 
           `-/+sssssssssssssssso+:`        Uptime: 44 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 1288 (pacman), 22 (flatpak) 
       `.://osssssssssssssssssssso++-      Shell: zsh 5.8 
      .://+ssssssssssssssssssssssso++:     Resolution: 1920x1080 
    .:///ossssssssssssssssssssssssso++:    DE: Plasma 5.23.5 
  `:////ssssssssssssssssssssssssssso+++.   WM: KWin 
`-////+ssssssssssssssssssssssssssso++++-   Theme: Breeze Light [Plasma], Arc-Dark [GTK2/3] 
 `..-+oosssssssssssssssssssssssso+++++/`   Icons: [Plasma], breeze [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Terminal: tilix 
  `:::::::::::::::::::::::::------``       CPU: Intel i3-1005G1 (4) @ 1.200GHz 
                                           GPU: Intel Iris Plus Graphics G1 
                                           Memory: 4712MiB / 7626MiB 
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
~ » inxi -Fazy                                                                                                                                                            mika@Luna
System:
  Kernel: 5.16.4-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=611866a2-d11d-4442-b786-7263350a926f rw quiet
    cryptdevice=UUID=b9e892a4-f9f8-403f-b606-27b363a97077:luks-b9e892a4-f9f8-403f-b606-27b363a97077
    root=/dev/mapper/luks-b9e892a4-f9f8-403f-b606-27b363a97077
    resume=UUID=665bc4e0-0faa-4bac-9fe7-ecfb2dfef3a7 loglevel=3 nowatchdog
    nvme_load=YES
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: docker wm: kwin_x11 vt: 7
    dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Aspire A514-53 v: V1.16
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: IL model: Sneezy_IL v: V1.16 serial: <superuser required>
    UEFI: Insyde v: 1.16 date: 01/18/2021
Battery:
  ID-1: BAT0 charge: 32.6 Wh (100.0%) condition: 32.6/53.0 Wh (61.6%)
    volts: 16.6 min: 15.4 model: PANASONIC KT004 AP19B5L type: Li-ion
    serial: <filter> status: Full cycles: 386
  Device-1: hid-f4:73:35:09:1d:b5-battery model: Keyboard K380 serial: N/A
    charge: N/A status: Discharging
CPU:
  Info: model: Intel Core i3-1005G1 bits: 64 type: MT MCP arch: Ice Lake
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xA6
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 160 KiB desc: d-2x48 KiB; i-2x32 KiB L2: 1024 KiB desc: 2x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1160 high: 1180 min/max: 400/3400 scaling:
    driver: intel_pstate governor: performance cores: 1: 1180 2: 1141 3: 1165
    4: 1156 bogomips: 9524
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Iris Plus Graphics G1 vendor: Acer Incorporated ALI
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300
  Device-2: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 1-6:4
    chip-ID: 04f2:b64f class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: HDMI1 res: 1920x1080 dpi: 102 size: 480x270mm (18.9x10.6")
    diag: 551mm (21.7")
  OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.3.5
    direct render: Yes
Audio:
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
    bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0401
  Device-2: C-Media USB PnP Sound Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2 chip-ID: 0d8c:013a
    class-ID: 0300
  Sound Server-1: ALSA v: k5.16.4-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000
    bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  IF-ID-1: br-2b12a360e95c state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  IF-ID-3: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
    mac: <filter>
  IF-ID-4: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IF-ID-5: veth745a397 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-10:5 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 4060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:
  Local Storage: total: 1.4 TiB used: 693.19 GiB (48.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: HBRPEKNX0202A
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s
    lanes: 2 type: SSD serial: <filter> rev: G002 temp: 34.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:7 vendor: Intel model: HBRPEKNX0202AO
    size: 27.25 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s
    lanes: 2 type: SSD serial: <filter> rev: K5110440 temp: 46.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM048-2E7172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 0001 scheme: GPT
Partition:
  ID-1: / raw-size: 69.85 GiB size: 68.2 GiB (97.64%) used: 25.85 GiB (37.9%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-b9e892a4-f9f8-403f-b606-27b363a97077
  ID-2: /boot/efi raw-size: 489 MiB size: 488 MiB (99.80%)
    used: 448 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-3: /home raw-size: 162.98 GiB size: 159.36 GiB (97.78%)
    used: 102.21 GiB (64.1%) fs: ext4 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-05a5ae76-4f16-418d-b6dd-70173c6d5b5e
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 10.25 GiB used: 7.8 MiB (0.1%)
    priority: -2 dev: /dev/nvme0n1p1 maj-min: 259:1
Sensors:
  System Temperatures: cpu: 55.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 287 Uptime: 45m wakeups: 3 Memory: 7.45 GiB used: 4.9 GiB (65.8%)
  Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0
  Packages: 1310 pacman: 1288 lib: 286 flatpak: 22 Shell: Zsh v: 5.8
  running-in: tilix inxi: 3.3.12

Welcome to the forum!

Can you elaborate, let’s start with spectacle… What option do you select for your screenshot? Can you describe your problem in more detail? Have you tried active window, whole desktop or selected region in your screen?

You could at least warn that you posted a link to an external file download in your link above… I don’t like that and not sure it is in line to forum rules and I would not have clicked on it.

With spectacle, this is the image that is produced whether it be Full Screen, Rectangular Region, Active Window, or Window Under Cursor
Full Screen

With Flameshot, this is the screenshot I get

With OBS-Studio, I took a screen capture video and this is the output

I can’t post the video to imgur because it throws an error when I try to

I apologize for this. If MEGA links aren’t allowed, what site should I post the video to share it with others in this forum? Thanks

I never use mega so I don’t know. Generally it should be sufficient to post the problem and system info (like you nicely did above :grin:) then forum users can ask some follow up questions.

I generally like to know what links are posted as I don’t click on Google drive or other video links… thanks for clarifying.

My guess is that you have some graphical glitches recorded. You could try disabling desktop effects on kde, I think it’s fn+F12 or Alt+Shift+F12 or similar shortcut. Another option is try modifying the renderer/compositor. I don’t use kde at the moment but for me these were kind of recurring bugs with plasma.

Check under graphical problems

https://wiki.archlinux.org/title/KDE#Graphical_problems

Another common thing is your graphics driver. Maybe worth a shot to try booting via lts kernel instead. If not installed, the welcome app has a link to install akm, in general it’s good to have a fallback kernel anyways.

Just a couple of options to try… More knowledge able KDE users may check in hopefully.

1 Like

There is an odd bug that affects screenshot applications in kde when using the xf86-video-intel driver.

If you have the xf86-video-intel package installed, you could try removing it (which will default to the modesetting driver) and reboot.

4 Likes

Welcome to the forum @akayashi_mika :balloon::tada::partying_face:

1 Like

Sorry for the late reply, life in school has been very busy lately. Removing xf86-video-intel fixed the screenshot problem. Thank you for this. I can now screenshare and send screenshots to my friends without any problems now

3 Likes

Thank you for the warm welcome! Out of all distros I tried, Endeavour OS has been my favorite. I’m planning to try Arch after I become more familiar with the system and when I’d have the time to do it. Looking forward for spending more time with you fam!

welcome and enjoy your stay here

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.