Screen brightness diminishes after attaching AC adapter

Whenever I attach the power adapter after booting my laptop the screen brightness diminishes to 10% or so, and I have to crank it up using the brightness buttons.

This is after booting only, if I pull it again and reattach it the screen stays on.
The same thing happens if I pull the plug after booting this laptop, Only once too.

Been searching the interwebs to no avail, the Dell chat refuses to help because the laptop came with Windose.

The same thing occurs when I’m running a live iso, Debian, Arch, Windows…

I hope anyone has got an idea how and where to look.

System:    Kernel: 5.12.14-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: Xfce 4.16.0 
           tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm4 vt: 7 dm: LightDM 1.30.0 
           Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 5505 v: 1.5.4 serial: <filter> Chassis: 
           type: 10 v: 1.5.4 serial: <filter> 
           Mobo: Dell model: 0YX59Y v: A01 serial: <filter> UEFI: Dell v: 1.5.4 date: 06/10/2021 
Battery:   ID-1: BAT0 charge: 39.8 Wh (100.0%) condition: 39.8/39.8 Wh (100.0%) volts: 12.7 
           min: 11.2 model: BYD DELL CF5RH13 type: Unknown serial: <filter> status: Full 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Info: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 type: MCP 
           arch: Zen 2 rev: 1 cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 28455 
           Speed: 1926 MHz min/max: 1400/2375 MHz boost: enabled Core speeds (MHz): 1: 1926 
           2: 1397 3: 1397 4: 1545 5: 1397 6: 2159 
Graphics:  Device-1: AMD Renoir vendor: Dell driver: amdgpu v: kernel bus-ID: 03:00.0 
           chip-ID: 1002:1636 class-ID: 0300 
           Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 3-2:3 
           chip-ID: 0c45:671b class-ID: 0e02 
           Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati 
           unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.12.14-arch1-1 LLVM 12.0.0) 
           v: 4.6 Mesa 21.1.4 direct render: Yes 
Audio:     Device-1: AMD vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 03:00.1 
           chip-ID: 1002:1637 class-ID: 0403 
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Dell 
           driver: snd_rn_pci_acp3x v: kernel bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480 
           Device-3: AMD Family 17h HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.14-arch1-1 running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.31 running: no 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell 
           driver: ath10k_pci v: kernel bus-ID: 02:00.0 chip-ID: 168c:003e class-ID: 0280 
           IF: wlan0 state: up mac: <filter> 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 3-3:4 
           chip-ID: 0cf3:e007 class-ID: e001 
           Report: bt-service: disabled note: bt-adapter can't run. 
Drives:    Local Storage: total: 238.47 GiB used: 104.49 GiB (43.8%) 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: BC511 NVMe 256GB size: 238.47 GiB 
           speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 11004101 scheme: GPT 
Partition: ID-1: / size: 224.51 GiB used: 104.47 GiB (46.5%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 511 MiB used: 17.7 MiB (3.5%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 8.8 GiB used: 512 KiB (0.0%) priority: -2 
           dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 61.2 C mobo: 37.0 C gpu: amdgpu temp: 44.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 223 Uptime: 9h 24m wakeups: 2545 Memory: 7.2 GiB used: 2.56 GiB (35.5%) 
           Init: systemd v: 248 Compilers: gcc: 11.1.0 Packages: pacman: 1091 Shell: Bash 
           v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.03 

I’ve seen some weird similar nature bug with my DELL Precision, which they fixed with BIOS update - try to search for changelog in your model’s bios to see what’s up…

Oh yeah - and DELL tech support is same crap as any other corporation, pointless :slight_smile:

I updated the bios yesterday, but that didn’t help.

Have you checked the settings in the xfce power management screen for brightness reduction?

bvCe4Yg

If it’s happening on booting i wonder if you need to set a kernel parameter like mine. I have an HP with 4700U and i there were error messages in dmesg and journalctl related to the backlight. I added to the default grub command line in /etc/default/grub

acpi_backlight=video 

and updated grub via

sudo grub-mkconfig -o /boot/grub/grub.cfg

I’ll check those things out tomorrow, Rick.
Actually, nothing is happening during booting or at all if I don’t touch the plug.

Changing the settings in the power manager didn’t matter.
Altering the grubline actually did!
Where did you find that on the net?

Problem solved. :+1:

1 Like

I had some error messages on mine in dmesg and journalctl related to the backlight and amd so i fixed the error messages on mine. I have since fixed many with same type of issue on Lenovo but they use a slightly different parameter such as acpi_backlight=vendor and there are a few others also. I use the following kernel documentation to look at hardware issues.

https://www.kernel.org/doc/Documentation/admin-guide/kernel-parameters.txt

Yes, I remember you telling me you added a parameter a couple of months ago.
And thx, it’s working fine now.
I found something here after it had been solved: https://wiki.archlinux.org/title/Backlight#Kernel_command-line_options

Yes that is it exactly. Some people have issues and resort to installing some backlighting packages. But on mine it works as it should and the Fkeys for brightness work also. I’m pretty sure yours would be similar. I never noticed the brightness changing from plugging in the charger but maybe it did that too. I wasn’t paying attention to that so much as looking at error messages. Mine are all clean now and i don’t have any issues.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.