Ryzen slows down i3wm?

Hello to all,

I am running Endeavour OS with i3wm. Programs, except the terminal, take an extremely long time to start. I have tried everything now. Promising was to boost GTK in the xinitrc file, but unfortunately without success.

The last idea left is that i3wm has problems with my processor. I have an AMD Ryzen 9 6900HX with Radeon Graphics (16) @ 3.300GHz in a UM690 from Minisforum.

However, I could not find anything about Ryzen processors and i3wm. Can anyone help me with this? Thanks a lot!

Referring to this thread:

maybe try removing xdg-desktop-portal-gnome ?

I did it before. Nothing changed.

hey welcome @ceha ! :enos:
i do run i3 on AMD Ryzen 9 5900X with no issue.
You do bail out picom?
And checked htop/glances/top for any strange load causing by some stuff?

journalctl -f while try to start apps that lag?
tried using LTS kernel?

1 Like

Thank you for pointing this out. Picom seems to be the problem. I copied the example.picom.conf to picom.conf and enabled it in the config file of i3wm. Various changes in picom.conf did nothing.
But if I just type ‘pkill picom’ in the terminal, after that everything runs fast and fine. I then tried to delete picom completely, but picom is not found then, although the path is shown at pacman -F or yay -F. What can I do?

picom is not installed?
yay -Qs picom

It is not installed by default on eos…

But i know default picom can cause issues in some setups (hardware) i used this: picom-tryone-git when using amd GPU (currently only have Nvidia installed)

I installed picom and then set the fading to false in picom.conf. Now everything works. Thanks for the help!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.