Running a command on startup (KDE)

Hello, I am trying to run ksuperkey on startup but KDE doesn’t seem to let me. I have tried all online solutions but nothing works including putting it as an application or running it as a script.

Doesn’t that just bind super to the applications menu? KDE can do that without ksuperkey. I thought I remember ksuperkey being an xfce thing. . .

Yep it does. I need ksuperkey or else my meta/super key won’t open the application menu

The question is why? Normally meta/super key works.

More than likely something you added changed it on you. Alt+F4 is the equivalent and will open the applications menu by default on KDE. (I’m pulling up a vm to show a few places you can set that option) You should NOT need ksuperkey for this to work.

1 Like

It doesn’t for me

I got a vm downloading. We’re taking the pup out for a walk, and we’ll see if we can get it back working for you again. I’m 99% sure it worked out of the box for you.

Do you use latte-dock? I remember my latte shortcuts doing something like that to me once.

Either way, I’m confident we can figure it out w/o ksuperkey.

Nevermind I think I found the issue. The Meta key was occupied by some line in kwinrc that I wrote when trying to fix this my initial meta key issue. Meta key did not work out of the box initially but now it works automatically without ksuperkey. Thank you anyway


Ya, something you did must have broken it. No idea what, but it works normally that way.

Glad it’s fixed.