Rofi-sensible-terminal fails

$ set TERMINAL footclient
$ rofi-sensible-terminal
returns “failed to find a suitable terminal !”
while I’m running that inside a perfectly suitable footclient instance…
since the man page says:
This wrapper script is necessary since there is no distribution-independent terminal launcher (but for example Debian has x-terminal-emulator). Distribution packagers are responsible for shipping this script in a way which is appropriate for the distribution.
I guess it’s the appropriate place to ask :wink:

ps: this rofi is “rofi-lbonn-wayland-git 1.7.0.wayland1.r56.g70efa84f-1” from AUR.

What does



From the rofi-sensible-terminal manpage it says it runs whatever is in the TERMINAL variable, so I’m guessing it needs to have something like /bin/footclient.

Try to run it like this:

TERMINAL=/usr/bin/footclient rofi-sensible-terminal

The path to footclient might be wrong, you can find it out by running

which footclient

It will probably return /usr/bin/footclient or something like that.

You do not use the set command to set a variable to some value, set is reserved for “options and positional parameters”. For variables, you use VARIABLE=value syntax.

mehdi@mehdi-80qr ~> source /etc/environment
/etc/environment (ligne 10) : Usage de '=' non supporté. Dans fish, veuillez utiliser 'set BROWSER /usr/bin/falkon'.
du fichier source /etc/environment
source : Erreur de lecture sur le fichier '/etc/environment'

that’s why I use set… sorry I should have precised I use fish.

Your command works but setting /etc/environment or whatever to then “source” it, doesn’t.

mehdi@mehdi-80qr ~> echo $TERMINAL

mehdi@mehdi-80qr ~> TERMINAL=/usr/bin/footclient rofi-sensible-terminal
mehdi@mehdi-80qr ~ [15]>


Then just use that command to launch rofi-sensible-terminal. Modify the appropriate desktop file or make a script that does it. Or look up how to use variables in fish.