[RISOLTO] Aggiornamento sistema NON va a buon fine

Ciao a tutti,
eccomi di nuovo a chiedere consigli , non riesco ad aggiornare il sistema da welcome, vi incollo l’errore

:Dimensione totale dei pacchetti da scaricare: 3,60 MiB
Dimension totale dei pacchetti da installare: 4073,51 MiB
Dimensione netta dell’aggiornamento: 40,35 MiB

:: Vuoi procedere con l’installazione? [S/n] s
:: Download dei pacchetti in corso…
graphviz-7.0.4-1-x86_64 3,6 MiB 645 KiB/s 00:06 [---------------------------------------------------------------------------------------] 100%
(425/425) verifica delle chiavi presenti nel portachiavi [---------------------------------------------------------------------------------------] 100%
(425/425) verifica dell’integrità dei pacchetti [---------------------------------------------------------------------------------------] 100%
errore: fwupd: la firma di “Frederik Schwan frederik.schwan@linux.com” ha un’affidabilità sconosciuta
:: Il file /var/cache/pacman/pkg/fwupd-1.8.7-2-x86_64.pkg.tar.zst è corrotto (il pacchetto non è valido oppure è corrotto (firma PGP)).
Vuoi eliminarlo? [S/n] s
errore: impossibile eseguire l’operazione richiesta (il pacchetto non è valido oppure è corrotto)
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

AUR controllo gli aggiornamenti:
:: Cerca su AUR per gli aggiornamenti…
→ Pacchetto AUR non trovato grub-tools grub2-theme-endeavouros ipw2100-fw ipw2200-fw nvidia-installer-db nvidia-installer-dkms
non c’è nulla da fare

cosa devo fare ? consigli ? ho letto un po in giro ma non trovo nulla

grazie a tutti
max
le caratteristiche
OS: EndeavourOS Linux x86_64
:+sssssssssso/. Host: BOD-WXX9 M1010 -/ossssssssssssso/. Kernel: 6.0.6-arch1-1
-/+sssssssssssssssso+: Uptime: 1 day, 10 mins
-:/+sssssssssssssssssso+/. Packages: 1112 (pacman) .://osssssssssssssssssssso+± Shell: bash 5.1.16
.://+ssssssssssssssssssssssso++: Resolution: 1920x1080
.:///ossssssssssssssssssssssssso++: DE: Plasma 5.26.2
:////ssssssssssssssssssssssssssso+++. WM: KWin -////+ssssssssssssssssssssssssssso+++± Theme: [Plasma], Breeze [GTK2/3]
..-+oosssssssssssssssssssssssso+++++/ Icons: [Plasma], breeze [GTK2/3]
./++++++++++++++++++++++++++++++/:. Terminal: konsole
`:::::::::::::::::::::::::------`` CPU: 11th Gen Intel i5-1135G7 (8) @ 4.200GHz
GPU: Intel TigerLake-LP GT2 [Iris Xe Graphics]
Memory: 3082MiB / 7748MiB

Ciao!
Hai ancora il problema o nel frattempo è stato risolto?

1 Like

@Massi22

Ho appena notato il tuo post.
Il motivo è un pacchetto archlinux-keyring troppo vecchio.
Si può risolvere con i comandi da terminale:

sudo pacman -Sy archlinux-keyring
sudo pacman -Syu
2 Likes