Right Click in Firefox: Menu won't stay open

Over the last few days, I’ve been experiencing one little problem with Xfce. I’ve looked online, but haven’t found this problem. What you find online is that a right click in Xfce in Firefox takes forever. Not in my case.

I will right click either on a link or a text box (such as in Google Translate), and the Contextual Menu flashes up, auto-selects the first thing on the list and dissappears instantly. I have to hold the right button down and then select what I want before I can release the right button on my mouse.

This isnt’ a deal breaker by any stretch, but it’s annoying! I seem to remember this happening once before. I thought I found the answer, but either it’s been pulled (maybe the website’s down, or discontinued?) or I’m confused. Since either is possible, I thought I’d come here for help. :grin:

My right click opens a dialogue box. No issue. Try another mouse just for fun. Oh by the way i wanted to ask what kernel you are running. I just installed and it hasn’t updated to 5.2.9 yet.

1 Like

Hi @ricklinux. I have a laptop. I have a Logitech USB Wireless Mouse that I use all the time. Thanks for the suggestion. I just tried the laptop’s trackpad right click button, and it does the same exact thing. Soooo, I’m thinking there’s a setting or configuration setting that’s mucked up somehow.

Has it always done this? Or is it a new problem?

1 Like

Maybe try the settings for the mouse and trackpad in settings. There are a number of settings.

New problem. Happened once before in the past with (I think) Antergos, but can’t find any postings on it.

Just checked, but nothing seems to change the action.

In Firefox you can change the context menu entry. Open Firefox and in the url box put
about:config
It will bring up a warning…just ignore
find this line

ui.context_menus.after_mouseup;false

Change the value to true
If this doesn’t work you can change it back.

4 Likes

Ta-Da! Works like normal, now! Thanks, @ricklinux! Life is good again.

1 Like

What fixed it?

Changing the Firefox config setting from false to true. Worked instantly!

Awesome! I wasn’t sure but it was a thought to try.

2 Likes

Good thought! :laughing:

I have done a lot of config stuff in Firefox on Windows over the years. Always trying things.

1 Like

This is marked solved, BUT, I’ve just opened an imgur account and want to see what happens when I drop the link here. This is a little video showing what had been happening before @ricklinux found the cure…

1 Like

So does it solve it on this? I see exactly what you meant? It automatically selects the first option and executes it.

@ricklinux I believe that thing shown on recording is firefox funcionality plus this config error combined, because:

  1. firefox has this function that when you press and hold right mouse button, and release it somwhere within dropdown menu, it will automatically execute thing beneath button, for example you can do “go back one page” in very convinient and effordless was
  2. becasue Adam’s config wasn’t leaving the box open, hitting RMB acted as he was pressing it, and releasing at “open link in new tab” which did what it says

I believie that Adam problem is solved, as he mentioned:

Note “before” :wink:

I know what was happening before. I gave him an option and he said it fixed it. I wasn’t sure if his final post meant something different after because of the following:

“This is marked solved, BUT, I’ve just opened an imgur account and want to see what happens when I drop the link here.”

Thought maybe it was still a problem. As far as Firefox goes i can right click and let go and this does not happen at all because the cursor is never inside the dialogue box when i let go of the button. Never seen that in all the years i have used Firefox. I know it’s a problem on some computers most likely laptops but i don’t know the answer why. I am a desktop person. I just know the fix worked but i was just checking if he found another issue. :thinking:

1 Like

Hi @ricklinux. Sorry for the confusion. I had opened the imgur account in preparation to be able to post the little video prior to your resolution. Your config fix worked right away. I put the video up to show what I had talked about earlier in case anyone else wasn’t sure about what was happening before. A little “show-and-tell”. Plus, since I’d opened the account, I thought I’d use it. :grin:

2 Likes

Actually it’s nice to see exactly what it was doing. It does it so fast it’s hard to tell what it’s doing.

1 Like