Resolved - Welcome App not appearing

I’m trying to install EOS onto a Lenovo Yoga 13. I downloaded the latest release ISO (endeavouros-2021.04.17-x86_64.iso), created a boot media with rufus following the instruction on wiki guide, and was able to boot into the live OS environment without issue.

  • the Welcome app does not launch on startup
  • Trying to click the “Install System” icon form the task bar results in the cursor spinning for a sec and nothing happens.
  • Trying to click the “Welcome” and “EndeavourOS log tool” icons from the EndeavourOS menu doesn’t do anything.

Not sure what else I should try. Thanks.


  • I tried using the latest dev build instead and the Welcome screen is now coming up. I’ll just proceed this way.


  • Now I’m receiving a eos-welcome: required file does not exist: ‘/usr/share/calamares/settings.conf_offline’ error when I choose online or offline.

I am not sure what you are referring to by the “latest dev build” but some of the pre-release ISOs don’t support running the installer from the welcome app. In those builds there should be separate icons to offline and online install.

It was endeavouros-devel-next-2021.06.20-x86_64.iso. I’ll try to look for those icons… Thanks.

If you have problems with the mirrors and the dev ISO, I’d recommend updating the mirrors (a Welcome button) before clicking the online/offline install button on the panel.

I ended up having someone help me with the installation. I’m not exactly sure how he fixed it. I think he booted using the latest release, and updated the installer before launching it or something.