Reseau inaccessible

Bonjour à tous,
Je suis nouveau sur ce forum. J’ai installé endeavouros il y a 3 ans et tout a fonctionné sans problème. Sur la dernière mise à jour, les cartes wifi et filaire sont vues mais stoppées et impossible de les activer. Merci de votre aide.

Pour info : Pc bureau -AMD 350 - 2 core 1,6 GHz - 8Gb Ram

Je ne parle pas français (en utilisant un traducteur) donc si quelque chose n’est pas clair, il suffit de demander.

Quel environnement utilisez-vous? (XFCE, Gnome, KDE) Ce serait important pour déterminer quel programme gère votre réseau. Ou, si vous savez lequel c’est, postez-le.

Thanks. xfce environment
Realtek RTL8111E

R8168 updated 2 days ago. when did you do the update ? i think rtl 8111e is part of that driveR.

C’est peut-être le même problème que j’ai eu. Vérifiez si vos périphériques réseau sont désactivés dans /etc/NetworkManager/NetworkManager.conf

the update was done on July 8.

Error! Bad return status for module build on kernel: 5.12.14-hardened1-1-hardened (x86_64)
Consult /var/lib/dkms/rtl8812au/5.1.5/build/make.log for more information.
==> Warning, `dkms install --no-depmod -m rtl8812au -v 5.1.5 -k 5.12.14-hardened1-1-hardened’ returned 10
==> dkms install --no-depmod -m vboxhost -v 6.1.22_OSE -k 5.12.14-hardened1-1-hardened

Indication in NetworkManager.conf : # See “man 5 NetworManager.conf” for details
Thats all.

u use hardened ? you need the dkms offcourse of r8168 in repo is linux & linux-lts like r8168 or r8168-lts

The problem is that everything is installed

you have all kernels also installed and different dkms drivers? enlighten please :slight_smile:

Est-il possible pour vous de poster le lien pour la commande suivante.

inxi -Faz --no-host | eos-sendlog

1 Like

[philippe@archtest ~]$ inxi - Faz --no-host | eos-sendlog
bash: inxi : commande introuvable
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0curl: (6) Could not resolve host:

[philippe@archtest ~]$

You seem to be using the hardened kernel. Maybe try to use the LTS-kernel instead, see if that works for you. I tried the zen-kernel (as I use that on my Arch-desktop too) which caused trouble in my laptop.

Start “akm” and select “linux-lts” and “linux-lts-headers” and “execute”. Then, in a terminal, execute

sudo nano /etc/default/grub

And change




if it isn’t already set. Execute

sudo grub-mkconfig -o /boot/grub/grub.cfg

and reboot when it’s done. You should now see the Grub-Menu at startup (if you haven’t had that already) ready to let you chose the kernel. Select the LTS-kernel and boot. Maybe that’ll work. :wink:

I have tried this method but when I open AKM I get the following message: Sorry, archlinux site is unavaible. it is recent. Thanks

Of course, my bad. Hmm, then

sudo pacman -S linux-lts linux-lts-headers

probably won’t work either, will it. I’m not certain if those packages lie around in the system somewhere by default, so I’d try it nonetheless.

If that doesn’t work - which I’m pretty sure it won’t - do you have a Live-medium you could boot the PC into? There you should get Internet. If yes, report back, and we’ll arch-chroot into your system to install the package manually.

But no, you have nothing to do with it, I tried to go through AKM and I got this answer.
I will prepare a live-cd and I will boot on it. I will keep you informed. Thank you.

Note: I have tested with trisquel 8.0, the LAN is working.

Good. Make sure it’s either the Arch or the EndeavourOS Iso.

Have you updated your system? Like

sudo pacman -Syu

You can download inxi with

sudo pacman -Syu inxi

And if you have no network connection, can you use your phone with USB (or wifi) tethering?

Also, you could use the ISO (I’m assuming it works, right?) and use arch-chroot and then update your system, and make the needed fixes (e.g. uninstall r8168).

In fact simply uninstalling package r8168 might do the trick:

sudo pacman -R r8168
1 Like

Sudo pacman -R r8168 : answer ; Error : unable to find the target