Replace Wayland for XOrg

Good morning, everyone!

I usually have a lot of visual glitches with Wayland. Is it possible to replace it with XOrg?
If so, can someone point me towards a tutorial?

Thanks!

When you’re at the log in screen, click on password field and you should see gear icon on bottom right. You can click and choose Xorg. I think default Gnome is Wayland.

6 Likes

Alternatively, you could edit /etc/gdm/custom.conf:

# GDM configuration storage

[daemon]
# Uncomment the line below to force the login screen to use Xorg
#WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

and change

#WaylandEnable=false

to

WaylandEnable=false

5 Likes

This worked! I didn’t even bother checking that gear because I only installed gnome this time. Thanks!

@pebcak thank you too for your suggestion on how to change it for GDM as well. =)

Remember to mark the post as the Solution.

I didn’t know we could do that. Thanks for the feedback!

1 Like

My language and keyboard is French, so if I made the above change would the language and keyboard revert to English? If so how to change in xorg?

Michael

Myself, I do use Gnome on Wayland on my laptop.
However testing the above and switching to Xorg did change neither the language nor the keyboard layout on this system.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.