Reinstall-kernels cmd not found

Hi there,

On my laptop, a HP victus 910 than after update, I’ve encountered an issue with kernel 6.4.12, and now corrected with the help of this troubleshooting: (in my case, it was the second option) :pray: :pray: :pray:
Just for my curiosity, I apologize if I’m not posting on the correct section, I’ve these questions:
1-when I’ve tried the first one, the command reinstall-kernels was not know. Is there a syntax error or something else missing on my system?
2- the file cmdline was a file to create this the command writen? this one is not present on my system.
3- about the grud added command, It will be necessary to keep it ad vitam eternam or just time to correct this issue
many thanks for your returns

1 Like

@joekamprad looks like it’s and old article that needs some re-write :upside_down_face:
Unless i’ve missed something, coz i’m an old grubber!

In that article, you use 1 or 2, not both.

If you are using grub, follow the instructions in section 2.

In section 3, if you are using grub, use sudo dracut-rebuild instead of sudo reinstall-kernels

I tried the first one without success, command not know, so I tried the second one and this one corrected my problem
As mentionned, the command reinstall-kernels was for me a command not found.

Yes, that is only for people who use systemd-boot. If you use grub, that command will not be available.