Reinstall EOS but script not running like before


I changed my hdd to sdd and reinstall eos kde. However, I use configurable button widget to run a script but is not running like used to be in the old installation.

the script is for organize (like hazel in mac to auto organize files according to rules) and is very simple:

echo “organize run”

If I run directly in konsole the command “organize run” it will run without problems. However, if I run in konsole the script (yes, the sh file already has the permissions to be executed) it will show

[user] ./
organize run

I do not know the reason that after reinstalling eos is not working like before. Any help is greatly appreciated.

You don’t need that “echo”. Change the line to

organize run

(without quotation marks) and it should work.

Thank you for the answer. It partially works, if I run in konsole ./ it will run without problems now. However, the strange thing is that when I use right click in dolphin and choose run in konsole it will say:

line 2: organize: order not found

and basically I think configurable button works that way. Still strange because before the reinstall it used to work fantastic… probably will have to reinstall again everything :sweat_smile:

Thank you again