Reflector-simple not working [resolved]

This morning I can’t seem to be able to use reflector-simple anymore: it just can’t find anything: “no mirrors found”, no matter which country I specify (it doesn’t even work with “Worldwide”). I tried that in a few computers and with different network connections, and the result is the same.

Yeah, I have the same problem with the normal reflector package from arch. Should be a bug or some other issues regarding getting the mirrorlist from the arch website.

Right! Even reflector just doesn’t work with the same problem

Consider using rate-mirrors, it sucks much less than reflector.

1 Like

Seems to have an issue for me, too, as it only outputs one single china server that doesn’t work. Reflector doesn’t suck and does exactly what it should. But there seems to be a problem with how those programs get their mirrorlists.

rate-mirrors --protocol=https --disable-comments arch                                            
Server =$repo/os/$arch

It’s not related to the app.

edit: looks like there are only a couple of mirrors that are synced at 100%. I tried with the option --completion-percent 98 so I could get enough mirrors in the list.

to the rescue…

I have issues with all tools to rank the mirrors… they gave me max 2 results…

something is screwed there… same for github actions using archlinux docker image… so n ot related to my network…

all the same reflector rate-mirrors

Found the same, seems both reflector and rate-mirrors are out of order now.

BTW, eos-rankmirrors is working… but it does not rank Arch mirrors unfortunately.

i am sure you could add this feature :wink: but lets wait a bit … we have no clue why this isn happening …

Yeah, probably the problems with those apps will be fixed quite soon.

Blocked installing OS from live usb. i check all mirrors before install… no mirrors found.If i try to install of course same error. Bad day to be merging from arc to endevour? Any work around?

Welcome to the forum! :smile:

Did you try the offline install?

I could try, worried once installed i still wont have access to further packages to complete my install? is is there a workaround for that?

@joekamprad thanks for bumping me over to this post :hearts:

creates a list you can use after uncommenting the servers this can be used on installer too before starting installer it will use it if you replace /etc/pacman.d/mirrorlist

You can use graphical Editor to open the file and remove the comments all at once replacing #Server with Server save the file and replace mirrorlist with it…

use sudo cp /path/to/your-manual-edited-mirrorlist /etc/pacman.d/mirrorlist

Same counts for using installer ISO at the moment do the same before starting installer to use the custom mirrorlist.

1 Like

You can manually set the mirrors in files /etc/pacman.d/mirrorlist.
And you can use
to help with that.

That i can do thank you so much! will i need to change anything back in the mirror list once this is sorted?

Thank you all for the fast help x

not that we know of at the moment , reranking mirrors can ba done and will overwrite existing mirrorlist anyway if you do so later…