Recent update and perhaps the new kernel seems to have introduced issues with my Realtek WiFi card and system shutdown

Hello everyone, I’m sorry that this, of all things, is the first post I create after my introduction, but I ran into some problems I couldn’t solve by myself.

First: My laptop (a Lenovo IdeaPad 5) has a WiFi card from Realtek, namely an RTL8852AE. I used to easily get this card to run by connecting my phone via USB, install rtw89-dmks-git from the AUR, and finally doing a quick sudo modprobe rtw89pci. Now, I’ve seen that after every kernel change the thing has to be rebuild, so I did as instructed and had yay rebuild it—at least I assume that’s what I did, because yay asked me if I wanted to “clean build” it and I told it to do so.
Now, however, I can’t activate it, as the modprobe command just returns an error:

sudo modprobe -v rtw89pci
insmod /lib/modules/5.16.0-arch1-1/updates/dkms/rtw89pci.ko.zst 
modprobe: ERROR: could not insert 'rtw89pci': Exec format error

This means that my laptop currently has no WiFi. I can work around that, but it is a tad annoying—aka I’m a bit freaked out. :sob:

Second issue: Before the most recent updates, booting and shutting down would show just a few messages, usually something about a dog that didn’t stop. I like dogs, so I never worried too much about it. “Let it play,” I thought. Ahem … Anyway, ever since today, my screen is flooded with messages during boot and shutdown processes. Most of them, again, seem fine, like:

Unmounting this and that …
Finished unmounting …
Detaching this and that …
Finished detaching …

etc. It’s a bit unusual to see all of this spelled out to me, but it’s nothing I should worry about, I think.

What I do worry about, however, is that the laptop won’t turn off on its own any more. After all these messages it now stops at kvm: exiting hardware virtualization and it stays that way, until I hold down the power button.

If anyone has a great idea or two on how to fix these issues, I’d be very grateful.

Here is some information about my system:

[ahf@xenon ~]$ inxi --admin --verbosity=7 --filter --width
  Kernel: 5.16.0-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=07cc1835-beed-4778-904c-f4c43240b11a rw quiet
    resume=UUID=b6a9446f-347e-4497-ac8d-a664aa56a419 loglevel=3 nowatchdog
    nvme_load=YES acpi_backlight=video
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: 82LM v: IdeaPad 5 14ALC05
    serial: <superuser required> Chassis: type: 10 v: IdeaPad 5 14ALC05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI: LENOVO v: G5CN20WW(V1.08)
    date: 06/30/2021
  ID-1: BAT1 charge: 49.4 Wh (85.6%) condition: 57.7/56.5 Wh (102.2%)
    volts: 12.4 min: 11.5 model: 0x53 0x4D 0x50 0x00 0x32 0x30 0x 0x4C 0x31
    0x39 0x4D 0x33 0x50 0x5650
    type: Li-ion serial: <filter> status: Discharging cycles: 8
  RAM: total: 15.03 GiB used: 2.48 GiB (16.5%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x68 (104) stepping: 1
    microcode: 0x8608103
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1396 high: 1397 min/max: 1400/4056 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 1397
    3: 1397 4: 1394 5: 1396 6: 1395 7: 1397 8: 1397 9: 1396 10: 1397 11: 1397
    12: 1397 bogomips: 50326
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc
    tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Lucienne vendor: Lenovo driver: amdgpu v: kernel
    bus-ID: 04:00.0 chip-ID: 1002:164c class-ID: 0300
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-3:2 chip-ID: 174f:2459 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x174mm (12.2x6.9")
    diag: 355mm (14")
  OpenGL: renderer: AMD RENOIR (DRM 3.44.0 5.16.0-arch1-1 LLVM 13.0.0)
    v: 4.6 Mesa 21.3.3 direct render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
    vendor: Lenovo driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x bus-ID: 04:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.0-arch1-1 running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    vendor: Lenovo driver: rtw89_pci v: kernel modules: rtw89pci port: 2000
    bus-ID: 03:00.0 chip-ID: 10ec:8852 class-ID: 0280
  IF-ID-1: enp4s0f4u2 state: unknown speed: -1 duplex: half mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-2: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IP v4: <filter> scope: global
  IP v6: <filter> virtual: stable-privacy scope: link
  WAN IP: <filter>
  Device-1: Xiaomi Mi/Redmi series (RNDIS) type: USB driver: rndis_host
    v: kernel bus-ID: 3-2:5 chip-ID: 2717:ff80 class-ID: 0a00 serial: <filter>
  Report: This feature requires one of these tools: hciconfig/bt-adapter
  Device-2: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-4:3 chip-ID: 0bda:4852 class-ID: e001 serial: <filter>
  Report: ID: hci0 rfk-id: 2 state: up address: N/A
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 592.04 GiB used: 31.64 GiB (5.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN730 SDBPNTY-512G-1101 size: 476.94 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 11190001 temp: 25.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk
    model: SSD PLUS 240GB size: 115.1 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 98.27 GiB size: 96.16 GiB (97.86%) used: 31.64 GiB (32.9%)
    fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 07cc1835-beed-4778-904c-f4c43240b11a
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: C309-0161
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 16.54 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3 label: swap
    uuid: b6a9446f-347e-4497-ac8d-a664aa56a419
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 260 MiB fs: vfat label: SYSTEM_DRV
    uuid: 3828-0EFF
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 475.69 GiB fs: ntfs
    label: Windows-SSD uuid: 6828297728294602
  ID-4: /dev/nvme0n1p4 maj-min: 259:4 size: 1000 MiB fs: ntfs
    label: WINRE_DRV uuid: 1C2229E72229C69C
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: Syntek Integrated Camera type: Video
    driver: uvcvideo interfaces: 3 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 174f:2459 class-ID: fe01 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-2:2 info: SanDisk Extreme Pro type: Mass Storage driver: uas
    interfaces: 1 rev: 3.2 speed: 5 Gb/s power: 896mA chip-ID: 0781:5588
    class-ID: 0806 serial: <filter>
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-2:5 info: Xiaomi Mi/Redmi series (RNDIS)
    type: Bluetooth,CDC-Data driver: rndis_host interfaces: 2 rev: 2.1
    speed: 480 Mb/s power: 500mA chip-ID: 2717:ff80 class-ID: 0a00
    serial: <filter>
  Device-2: 3-3:2 info: Shenzhen Goodix Goodix FingerPrint Device
    type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 27c6:55a2 class-ID: ef00
  Device-3: 3-4:3 info: Realtek Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.0 speed: 12 Mb/s power: 500mA
    chip-ID: 0bda:4852 class-ID: e001 serial: <filter>
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 35.1 C mobo: 35.0 C gpu: amdgpu temp: 32.0 C
  Fan Speeds (RPM): N/A
  Processes: 308 Uptime: 3m wakeups: 346 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 Packages: pacman: 1069 lib: 300 Shell: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.11

Support for this chipset was added natively to 5.16, and the DKMS version is broken with 5.16. This means you need to remove the DKMS package if you’re using 5.16.

I submitted a change to the AUR package that will limit the DKMS module build to supported kernels, but it hasn’t been included yet.


Ohhh, well that is amazing news, I wasn’t aware! So that means, I can remove the AUR package and the WiFi should work again?

For your second issue:
The watchdog not stopping message is normal.

As for what could be causing the hang, a log might help
journalctl -b -1 -n400 | eos-sendlog
Where -b is current boot, -1 is previous boot, -n400 is last 400 lines of journal. You might need more or less lines depending on your system. The pipe eos-sendlog uploads it to for easy viewing.

Without more info, an option you might try is editing /etc/mkinitcpio.conf and adding shutdown to your hooks
Then regenerate it sudo mkinitcpio -P and reboot

That just makes sure any kernel modules you have loaded are all removed. Probably won’t make a difference as that’s pretty rare they’re not.

1 Like

I have now removed the AUR package for the rtw89 driver and this actually solved both issues. No more message flooding, nor does the laptop hang while shutting down. The WiFi works again as well. Beautiful. I have marked @jonathon’s post as the solution, but I do thank you for your reply @KDen.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.