Reboot Recommended on every boot

eos-reboot-required2 pop-ups on every fresh boot

I usually just close it, but its quite annoying

How do I make this go away?

I’m using KDE Plasma if that is relevant

Are you booting a VM (virtual machine)?

no, EOS is bare

Where do you see this pop-up - while your system is booting, or after you’ve logged? Or somewhere else, like after doing a system update?

EDIT: Based on this thread, it seems you see this in the terminal after doing an update, in which case it means that you can probably ignore it if you didn’t update a core system utility.

What’s the version of package eos-bash-shared on your system?

Can you show the output of

systemctl status eos-reboot-required.timer

If it is active, run

systemctl disable eos-reboot-required.timer

and reboot to see if it helped.

I dont know how to heck eos-bash-shared

but changing eos-reboot-required.timer worked

Great that it helped! :smile:

You can find the package version with command

pacman -Q eos-bash-shared

and more about pacman with command

man pacman

Thanks a lot

just checked, eos-bash-shared 24.10-1

1 Like

Hello,

I am having the same issue. I am on Gnome and running inside a VM.

I ran eos-pacdiff and resolved all files, but still after a fresh boot I am having the issue.

Here is the version of the package on my system:

$ yay -Q eos-bash-shared 
eos-bash-shared 24.12-1

Is there a remedy? This is rather annoying.

Is this just masking the issue? In other words, does this stop all future notifications (even if correct)?

It will remove the timer from active timers. After reboot it should not run anymore.
And you can add option --now to stop this timer immediately.

Edit: misread your post, sorry about that.

Just built version 24.13-1 of package eos-package-shared that has a new config option
EOS_REBOOT_RECOMMENDING
in file /etc/eos-script-lib-yad.conf which enables or disables reboot notifications. By default it is yes for backwards compatibility.

Note: it will take some time to reach all mirrors.

1 Like

I am not sure I have communicated properly my issue. Right now, the update has hit my box and here is my state after a fresh reboot:

$ cat /etc/eos-script-lib-yad.conf  | grep REB
## EOS_REBOOT_RECOMMENDING specifies if the reboot recommendation notification
EOS_REBOOT_RECOMMENDING=yes

$ systemctl status eos-reboot-required.timer
○ eos-reboot-required.timer - Notify about reboot on special conditions.
     Loaded: loaded (/usr/lib/systemd/system/eos-reboot-required.timer; enabled; preset: disabled)
     Active: inactive (dead)
    Trigger: n/a
   Triggers: ● eos-reboot-required.service

$ systemctl status eos-reboot-required.service
○ eos-reboot-required.service - Notify about reboot on special conditions.
     Loaded: loaded (/usr/lib/systemd/system/eos-reboot-required.service; disabled; preset: disabled)
     Active: inactive (dead)
TriggeredBy: ○ eos-reboot-required.timer

So the problem has just occured: as I type this I got a notification I need to reboot. I have literally just rebooted and there have been no updates since then, so why am I still being asked to reboot?

I don’t mind the notification (I like it) but the problem is that this is clearly a false reboot request as I have installed nothing since my last reboot.

Right now, after getting the request, I see:

$ systemctl status eos-reboot-required.timer
○ eos-reboot-required.timer - Notify about reboot on special conditions.
     Loaded: loaded (/usr/lib/systemd/system/eos-reboot-required.timer; enabled; preset: disabled)
     Active: inactive (dead) since Wed 2024-03-20 13:23:50 GMT; 1min 40s ago
   Duration: 76ms
    Trigger: n/a
   Triggers: ● eos-reboot-required.service

Mar 20 13:23:50 ironyman systemd[1]: Started Notify about reboot on special conditions..
Mar 20 13:23:50 ironyman systemd[1]: eos-reboot-required.timer: Deactivated successfully.
Mar 20 13:23:50 ironyman systemd[1]: Stopped Notify about reboot on special conditions..

$ systemctl status eos-reboot-required.service
○ eos-reboot-required.service - Notify about reboot on special conditions.
     Loaded: loaded (/usr/lib/systemd/system/eos-reboot-required.service; disabled; preset: disabled)
     Active: inactive (dead) since Wed 2024-03-20 13:23:51 GMT; 1min 41s ago
TriggeredBy: ○ eos-reboot-required.timer
    Process: 6717 ExecStart=/usr/bin/eos-reboot-required3 (code=exited, status=0/SUCCESS)
   Main PID: 6717 (code=exited, status=0/SUCCESS)
        CPU: 75ms

Mar 20 13:23:50 ironyman systemd[1]: Starting Notify about reboot on special conditions....
Mar 20 13:23:51 ironyman su[6727]: (to myuser) root on none
Mar 20 13:23:51 ironyman su[6727]: pam_unix(su:session): session opened for user myuser(uid=1400601103) by>
Mar 20 13:23:51 ironyman su[6727]: pam_unix(su:session): session closed for user myuser
Mar 20 13:23:51 ironyman systemd[1]: eos-reboot-required.service: Deactivated successfully.
Mar 20 13:23:52 ironyman systemd[1]: Finished Notify about reboot on special conditions..

So it seems to me that this timer is configured to fire a few seconds after startup, and does this:

  • checks whether any package was installed since the system started that requires the reboot
  • displays a notification if this is the case

So, in my case, this happens after EVERY reboot even if no new packages have been installed…

Now, if I disable the timer, I expect I will stop getting the false notification. But then would that mean I never get a notification again? Would disabling it mean that if I do install something that requires a reboot I am NOT notified?

Hope I’ve managed to state my question clearly.

Thanks!

Change yes to no on that line only if you don’t want any such notifications.

Otherwise it should be enough to disable the reboot timer if it is on just before rebooting.

And note, it is not a requirement to reboot, but simply a statement that recommends rebooting since some essential system software has changed.

Also, please make sure that you have system fully updated.
Especially, check the IgnorePkg setting in your /etc/pacman.conf.

I have this exact same problem, and it’s very frustrating reading this thread and not seeing an actual fix and people being dismissive of the problem or not reading the actual problem statement.

I agree with tuxaholic, I WANT the reboot notification when reboots are valid. I also realize that it’s just a suggestion, but I like the reminder.

What I want it to do is stop giving false notifications.

My system is fully updated. I have no packages ignored. It’s been doing this for months now.