Really wanted to switch to KDE, but

The simplest things still don’t work or crash. For example, I have an Arch KDE VM that, after a few minor updates, works great - no KWin crashes, no issues with any apps, theming changes are flawless. However, on my real hardware (currently using EOS XFCE) I can’t get any new themes without either the System app crashing, KWin closing, or the theme refusing to apply (tried 4 different ones, all of which work on my 3 other KDE-based VMs).

Here’s my system info, in case someone thinks this is hardware-related:

$ inxi -Faz
System:    Kernel: 5.10.74-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: initrd=\EndeavourOS\amd-ucode.img 
           root=UUID=b6626456-c5e2-4f64-8185-bce57f2bfbc5 rw rootflags=subvol=@ loglevel=3 
           nowatchdog resume=UUID=f0eef397-b328-4c1e-997b-546af5354ed6 
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 
           dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME X470-PRO v: Rev X.0x serial: <filter> 
           UEFI: American Megatrends v: 5854 date: 07/13/2021 
CPU:       Info: 8-Core model: AMD Ryzen 7 2700X socket: AM4 bits: 64 type: MT MCP arch: Zen+ 
           family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D cache: L1: 768 KiB 
           L2: 4 MiB L3: 16 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
           bogomips: 118397 
           Speed: 4043 MHz min/max: 2200/3700 MHz base/boost: 3700/4350 boost: enabled 
           volts: 1.2 V ext-clock: 100 MHz Core speeds (MHz): 1: 4043 2: 2030 3: 4049 4: 4014 
           5: 4058 6: 4059 7: 4053 8: 4056 9: 4039 10: 4052 11: 4058 12: 4056 13: 4058 14: 4065 
           15: 4064 16: 2034 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 470.74 
           alternate: nouveau,nvidia_drm bus-ID: 08:00.0 chip-ID: 10de:1b81 class-ID: 0300 
           Display: server: 1.20.13 compositor: xfwm4 v: 4.16.1 driver: loaded: nvidia 
           unloaded: fbdev,modesetting,vesa alternate: nouveau,nv 
           resolution: <missing: xdpyinfo> 
           OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 
           direct render: Yes 
Audio:     Device-1: NVIDIA GP104 High Definition Audio driver: snd_hda_intel v: kernel 
           bus-ID: 08:00.1 chip-ID: 10de:10f0 class-ID: 0403 
           Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus-ID: 0a:00.3 chip-ID: 1022:1457 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.74-1-lts running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.38 running: no 
Network:   Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel port: e000 
           bus-ID: 06:00.0 chip-ID: 8086:1539 class-ID: 0200 
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb 
           v: 0.8 bus-ID: 1-5:2 chip-ID: 0a12:0001 class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> 
Drives:    Local Storage: total: 5.92 TiB used: 1.33 TiB (22.5%) 
           ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDH3512G size: 476.94 GiB 
           block-size: physical: 512 B logical: 512 B sata: 3.3 speed: 6.0 Gb/s type: SSD 
           serial: <filter> rev: 7000 temp: 26 C scheme: GPT 
           SMART: yes state: enabled health: PASSED on: 2y 34d 23h cycles: 710 read: 11.5 MiB 
           written: 7.3 MiB 
           ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SDSSDH3 2T00 
           family: Marvell based SSDs size: 1.82 TiB block-size: physical: 512 B logical: 512 B 
           sata: 3.3 speed: 6.0 Gb/s type: SSD serial: <filter> rev: 30RL temp: 32 C scheme: GPT 
           SMART: yes state: enabled health: PASSED on: 1y 214d 11h cycles: 437 
           ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital model: WD My Book 25DA 
           drive model: WD40EZRZ-00GXCB0 family: Blue size: 3.64 TiB block-size: 
           physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD rpm: 5400 
           serial: <filter> drive serial: <filter> rev: 3002 drive rev: 80.00A80 temp: 37 C 
           scheme: GPT 
           SMART: yes state: enabled health: PASSED on: 204d 22h cycles: 697 
Partition: ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 23.69 GiB (23.7%) fs: btrfs 
           block-size: 4096 B dev: /dev/sdb1 maj-min: 8:17 
           ID-2: /boot/efi raw-size: 16 GiB size: 15.99 GiB (99.93%) used: 854.5 MiB (5.2%) 
           fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 500 GiB size: 500 GiB (100.00%) used: 25.64 GiB (5.1%) 
           fs: btrfs block-size: 4096 B dev: /dev/sdb3 maj-min: 8:19 
           ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%) used: 23.69 GiB (23.7%) 
           fs: btrfs block-size: 4096 B dev: /dev/sdb1 maj-min: 8:17 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 32 GiB used: 1024 KiB (0.0%) priority: -2 
           dev: /dev/sdb2 maj-min: 8:18 
Sensors:   System Temperatures: cpu: 48.8 C mobo: N/A gpu: nvidia temp: 50 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 33% 
Info:      Processes: 432 Uptime: 31m wakeups: 0 Memory: 31.33 GiB used: 4.04 GiB (12.9%) 
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1259 
           lib: 330 Shell: fish (sudo) v: 3.3.1 default: Bash v: 5.1.8 
           running-in: xfce4-terminal inxi: 3.3.06

This is my 3rd attempt to try out KDE; the first 2 (openSUSE and Debian 10) were also failures.

Which themes are you trying to apply?

I’m shocked by that. Debian 10 could run on a toaster I think.

I cannot even fathom what makes KDE so special to your computer it doesn’t work on it while other DEs are good to go.

How did you install the DE? Is it a clean install?

In this case no, I just added it afterwards: yay -S plasma-meta kde-applications-meta

Could not agree more. Again, my 3 VMs - Debian 9, Arch, and openSUSE - all work great and suffer none of the errors in my OP.

One in particular is Fancy-Global, but I also tried a couple of others with no luck. I should probably try a clean install, but that’s a project for another day.

I just installed fancy-global with no issues.



I must be KDE-cursed, then.

I love KDE, but everything that depends on downloads from their store seems to be a desaster. Whenever I try to download a theme or splashscreen or whatever it takes forever and I’m just not able to figure out if the download already started or what the problem is. Sometimes I get a message telling me that the file couldn’t be found…

1 Like

Yep, had the same problem on Arch. I waited over 5 minutes for a simple SDDM theme to download/install, with no indications as to what was going on.

It’s better to stay away from those things that don’t work. I just stick to known good. I have no issues.


So i just removed fancy-global but not all things remove that easily in one action. Somethings have to be removed in other locations.

I figured it was time to try it on real hardware after my Arch VM became stable. In the beginning, I was crashing KWin regularly when making almost any settings changes via the Settings app. This seemed to be resolved, so I’ll try again with a fresh install.

You installed kde-applications-meta? You must really like k* apps.

That being said, I don’t think that is your issue.

However, installing plasma over whatever your prior DE was might be your issue.

Try creating a new clean user account and see if the issues persist there.


Thanks to everyone for the great input. I think I will plan on installing EOS w/KDE fresh in the near future; just gotta get a list of all the apps I’ve installed.

1 Like

I have it book marked on my computer, but I’m sure someone will post it. But you can save your installed programs to a text file and just download them via the file nice and easily.

pacman -Qqe > mypackages

The current semi-official list of plasma packages in EOS is here:

So if you want to install KDE packages manually, this is a good starting point.

1 Like