Random suspend after boot directly at login screen

Dear Community,

I have the following problem with no apparent pattern:

Rarely my laptop jumps directly into suspend after boot when the login screen should appear.

I can see it because the LED of the Thinkpad and possibly the one of the docking station are blinking.

This happens when using the docking station or with a USB-C to Displayport adapter.
In both cases, the laptop lid is closed when this happens.
This behavior rarely occurs.

It seems as if the system ignores that I turned off Supend when closing the lid.

I have looked through the journalctl but can’t figure it out.

Can you identify a cause for this behavior?

Thank you very much! :purple_heart:

pastebin of journalctl --since today

inxi -Fz

inxi -Fz
Kernel: 6.5.3-arch1-1 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.27.8
Distro: EndeavourOS
Type: Laptop System: LENOVO product: 20L8S9GC00 v: ThinkPad T480s
Mobo: LENOVO model: 20L8S9GC00 v: SDK0J40697 WIN
serial: UEFI: LENOVO v: N22ET75W (1.52 )
date: 09/28/2022
ID-1: BAT0 charge: 51.0 Wh (100.0%) condition: 51.0/57.0 Wh (89.4%)
Info: quad core model: Intel Core i5-8350U bits: 64 type: MT MCP cache:
L2: 1024 KiB
Speed (MHz): avg: 600 min/max: 400/3600 cores: 1: 800 2: 800 3: 800 4: 400
5: 400 6: 400 7: 400 8: 800
Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Device-2: Chicony Integrated Camera (1280x720@30) driver: uvcvideo
type: USB
Display: wayland server: X.org v: with: Xwayland v: 23.2.0
compositor: kwin_wayland driver: X: loaded: modesetting dri: iris gpu: i915
resolution: 2560x1440
API: OpenGL v: 4.6 Mesa 23.1.7-arch1.1 renderer: Mesa Intel UHD Graphics
620 (KBL GT2)
Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
Device-2: Lenovo ThinkPad Thunderbolt 3 Dock Audio
driver: hid-generic,snd-usb-audio,usbhid type: USB
API: ALSA v: k6.5.3-arch1-1 status: kernel-api
Server-1: PipeWire v: 0.3.79 status: active
Device-1: Intel Ethernet I219-LM driver: e1000e
IF: enp0s31f6 state: down mac:
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
IF: wlan0 state: up mac:
Device-3: Lenovo ThinkPad TBT3 LAN driver: r8152 type: USB
IF: enp11s0u1 state: down mac:
Local Storage: total: 476.95 GiB used: 36.34 GiB (7.6%)
ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520
SDAPMUW-256G-1101 size: 238.47 GiB
ID-2: /dev/nvme1n1 vendor: Lenovo model: LENSE30256GMSP34MEAT3TA
size: 238.47 GiB
ID-1: / size: 237.49 GiB used: 36.24 GiB (15.3%) fs: btrfs dev: /dev/dm-0
ID-2: /home size: 237.49 GiB used: 36.24 GiB (15.3%) fs: btrfs
dev: /dev/dm-0
ID-3: /var/log size: 237.49 GiB used: 36.24 GiB (15.3%) fs: btrfs
dev: /dev/dm-0
ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%)
file: /swap/swapfile
System Temperatures: cpu: 42.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 241 Uptime: 17m Memory: total: 8 GiB note: est.
available: 7.51 GiB used: 4.02 GiB (53.5%) Shell: Bash inxi: 3.3.29

Happened again just now.

Ideas anyone? :smiling_face_with_tear:

Where did you turn it off? If you turned it off in the KDE settings, that may not be enought–don’t forget, KDE hasn’t actually started yet when you are on the SDDM screen.

logind.conf will handle lid switch events prior to your desktop environment being loaded. This person made a convenient one-liner for making the necessary edits to resolve the exact issue you are dealing with:


Same here on Arch (current) on Lenovo T14s (current firmware).
A minimal Arch+SDDM+KDE installation leads to my system booting to suspend when reaching the login screen …

# echo -e "\nHandleLidSwitch=ignore\nHandleLidSwitchExternalPower=ignore" >> /etc/systemd/logind.conf

solved it for me since I don’t want my device to do anything upon lid open/close anyway.

Technically, I would say creating a drop-in file in /etc/systemd/logind.conf.d/ would be a better solution because you won’t have to deal with a .pacnew file if logind.conf gets updated, but either way it should resolve your issue.


Well this is a clever idea.

Its just so weird, that it happens randomly.

I’ll try your solution and will report back if it happens again!
Thank you very much!

Well it did not happen ever since.

Thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.