R8168 no ethernet

Hi,
I have no ethernet on my EOS i3
I do have ethernet when booted into Manjaro, Archbang or win10 on same computer with same ethernet cable
Wifi is working

I have the following results:

$ yay r8168
5 aur/r8168-pf 8.045.08-1 (+0 0.00) (Orphaned) 
    A kernel module for Realtek 8168 network cards(pf kernel)
4 aur/r8168-ck 8.048.03-1 (+1 0.00) (Orphaned) 
    A kernel module for Realtek 8168 network cards (linux-ck)
3 aur/r8168-dkms 8.049.02-1 (+19 1.12) 
    A kernel module for Realtek 8168 network cards (DKMS version)
2 community/r8168-lts 8.049.02-41 (708.2 KiB 705.8 KiB) (Installed)
    A kernel module for Realtek 8168 network cards for linux-lts
1 community/r8168 8.049.02-46 (72.2 KiB 69.8 KiB) (Installed)
    A kernel module for Realtek 8168 network cards
$ uname -r
5.10.88-2-lts
sudo modprobe r8168
modprobe: FATAL: Module r8168 not found in directory /lib/modules/5.10.88-2-lts

Can anyone help me please?

As far as I know you were given the option to choose the r8169 or r8168 driver during install, default is r8169 which works fine for most people.

Could you provide inxi -FAZ --no-host | eos-sendlog

and sudo dmesg | grep r81

1 Like

Thanks

With wifi on

$ inxi -FAZ --no-host | eos-sendlog
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2333    0    24  100  2309     37   3608 --:--:-- --:--:-- --:--:--  3651
https://clbin.com/cHzFD

$ sudo dmesg | grep r81
[sudo] password for leigh: 
[    0.054153] percpu: Embedded 64 pages/cpu s225280 r8192 d28672 u524288
[    0.054164] pcpu-alloc: s225280 r8192 d28672 u524288 alloc=1*2097152

With wifi disabled

$ inxi -FAZ --no-host | eos-sendlog
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (6) Could not resolve host: clbin.com

Also prvide output of sudo lsmod | grep r81 please

Looks like the driver is not loaded and I dont have the knowledge why that happened. I think you can load it manually like so:
sudo nano /etc/modprobe.d/ethernet.conf

and paste the following in there:

options r8169

Save the file and reboot.

sudo lsmod | grep r81 gives no output

options r8169 rather than r8168 ?

Yes r8169 should be fine

no luck

sudo nano /usr/lib/modprobe.d/r8168.conf
shows r8169 blacklisted

No idea what that’s all about but is from my initial searches before asking here

Remove that line that says blacklist r8169 and save the file. That should do it. Or remove r8168.conf completely.

sudo pacman -R r8168

file /usr/lib/modprobe.d/r8168.conf is from package r8168.

cd /usr/lib/modprobe.d

ls

delete that file and reboot:

sudo rm -r /usr/lib/modprobe.d/r8168.conf

1 Like

Nearly!
That didnt work but when took the blacklist r1869 line out of /usr/lib/modprobe.d/r8168-lts.conf it worked!

Thanks!

Before I mark as solved - what did I just do?
Did I swap from r8168 to 8169 drivers?
Can I now uninstall r8168 and r8168-lts?
Why did I have that problem - is there a problem with the r8168 drivers?

Yes do what @Balder said and mark his answer as the solution.

2 Likes

Thanks!
I did pacman -R for r8168 and r-8168-lts

Since there were then no r8168.conf of r8168.lts files in /usr/lib/modprobe.d I didnt need to remove them

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.