PulseAudio not showing soundcard/port but ALSA shows

My sound settings isn’t listing all the available connected audio devices. I had creative sound blaster soundcard usb plugged in.

Running inxi -F:

...
Audio:
  Device-1: NVIDIA GA102 High Definition Audio driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Device-3: Creative Sound Blaster X7 type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.1.6-arch1-3 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.64 running: yes
...

When I ran aplay -l | grep card

card 1: NVidia [HDA NVidia], device 3: HDMI 0 [LG Ultra HD]
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
card 2: Generic [HD-Audio Generic], device 0: ALCS1200A Analog [ALCS1200A Analog]
card 2: Generic [HD-Audio Generic], device 1: ALCS1200A Digital [ALCS1200A Digital]

However, I am not able to select Sound Blaster X7 as output from PulseAudio. There is a particular sequence where I first logged into windows, have sound output from X7, then restart into endeavouros (dual boot), and at first PulseAudio was able to select X7 as sound output and I was able to hear sound from it. But after turning the device on and off, PulseAudio was not able to detect it anymore. I could also find X7 from alsamixer. I’ve also tried different sound inputs (3.5mm line out, arctis 7 USBC and I was able to select it from PulseAudio.

There seems to be some race condition going on, after restarting it with my X7 turned on, I now can’t select it from pulse audio as output.