Pulseaudio automatically increases volume while recording; how do I fix?

So far, the only thing that I have done is add this pulseaudio profile for run this to improve the echo cancellation, and have tried to diagnose this using the Archwiki’s method.
When I try to record with OBS, and run Audacity at a low volume on my USB Samson Meteor Mic, the volume at some somewhat random point will rise to 100 or above, causing (obvious) problems post recording.
Has anyone else had this problem or have some insight was to diagnose it? I couldn’t find anything online about it strangely enough.

Sounds like flat-volumes to me.

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Volume_gets_louder_every_time_a_new_application_is_started

Or, this “automatic adjustment”/“mic boost” feature:

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Microphone_distorted_due_to_automatic_adjustment

1 Like

Oh yes, I forgot to add that I did try to do both the “auto adjustment/mic boost” feature, and make sure flat-volumes was disabled. They didn’t seem to make a difference unfortunately. Strangely enough, it seemed like flat-volumes was disabled by default as well.

So are you recording with a mic? (USB Samson Meteor Mic) I wonder if it is the auto volume in pulse or auto gain of mic?

Edit: Are you able to open alsamixer in the terminal and turn off mic boost.

1 Like


As far as I can tell, there doesn’t seem to be a “mic boost” option for my microphone. Yes, I made sure that it was explicitly recording the Samson Mic; I disabled my laptop and my headset internal mics to ensure that only the Samson would be going through.

Those are the Playback controls. Press F4 and have another look.

1 Like

Pardon my ignorance. Are would a mic boost option be a color indicator or something instead of being labeled in text?

Ah, no, if it was present it should be there and obvious.

You could also check the Pulseaudio sink (F6) and check that it’s not getting involved.

mic3
This is what I get with [F6]

OK. 

I’m going to try and reset my Pulseaudio config files and see if that will make a difference. I did a noise cancellation script. I didn’t do any recordings before then. We’ll see how it goes.

This is it Mic gain.

This is it Mic gain.

I beg your pardon?

Try muting the mic gain.

1 Like

muting the mic gain

Like within ASLA mixer, or Audacity, some other place?

In the Alsa mixer just to see if it stops the volume from increasing.

1 Like

In the Alsa mixer just to see if it stops the volume from increasing.

Sounds good, will try when I can. I’m doing a test run to see if it was a config error. As we speak I’m recording with only Audacity, and then I will try to do OBS + Audacity. If the problem still persists, I will give it a try!

You could try turning it off first and then turning it down. It’s set at 10 Decibel currently.

1 Like

Maybe, so far it seems like whatever commands I did to make a noise cancellation profile was the problem. Although, I can’t seem to understand why.
I’ll see if I can do the Arch Wiki’s noise cancellation profile commands and see if the results are the same or different.

1 Like

I never bothered to come back and say if the config was the problem or not. I just came here to say after a few months of testing that it was. Such a shame, but in the end I learned better practices for audio recording in general! Noise gates and recording -12dB for me!

2 Likes