Problems with RX 5700 (coming from Manjaro)

I have some problems to properly set up my AMD GPU (Radeon RX 5700). With Manjaro it works out of the box with perfect performance (stable and high fps) inside games. (Dota2, Overwatch, Ori and the will fo the wisps).

Somehow the ACO (for faster shader compiler) doesn’t work properly compared to Manjaro and inside games I overall have less performane and small stutters. I pretty much worked through the whole Arch Wiki (metaphorically speaking) and tried many different things, but I simply can’t get it to work under EndeavourOS.

Somebody have any tips on setting up my GPU? There must be some small thing Manjaro already has out of the box, that my EOS install doesn’t have.

Edit: My bad it’s an Radeon RX 5700.

1 Like

My 5500M, which is also Navi, needs the amdgpu.runpm=0 kernel flag to work stable.


According to this, it’s for laptops.

Override for runtime power management control for dGPUs in PX/HG laptops. The amdgpu driver can dynamically power down the dGPU on PX/HG laptops when it is idle. The default is -1 (auto enable). Setting the value to 0 disables this functionality.

I guess it won’t hurt to try it later today, but at first glance it doesn’t seem to be to problem.

My assumption was the same, but I know a 5700 XT user, who claimed it helped him.

just fyi RTX is nvida, your GPU is just a 5700XT and if youre searching for solutions you will really butcher your results including RTX when it has nothing to do with your card.

That said follow the arch wiki, lutris wiki, or gloriouseggrolls guides on getting out of wine dependency hell,etc. may be what youre looking for

1 Like

My bad. It’s an Radeon RX 5700.

you could try this from the chaotic-aur

I did not have stuttering issues with my 5700 xt but i did have issues with it just rebooting the whole pc, I moved to the linux-mainline kernel to get the 5.8 kernel early and haven’t had any other issues.

I am using the mesa drivers with lib32-mesa, lib32-vulkan-radeon and vulkan-radeon.

I also made sure to install all of the packages listed for lutrus.
From their wiki:
sudo pacman -S lib32-mesa vulkan-radeon lib32-vulkan-radeon vulkan-icd-loader lib32-vulkan-icd-loader

Then Install all the packages for
sudo pacman -S lib32-gnutls lib32-libldap lib32-libgpg-error lib32-sqlite lib32-libpulse

I then made sure to get all the listed packages for Wine:
sudo pacman -S wine-staging giflib lib32-giflib libpng lib32-libpng libldap lib32-libldap gnutls lib32-gnutls mpg123 lib32-mpg123 openal lib32-openal v4l-utils lib32-v4l-utils libpulse lib32-libpulse libgpg-error lib32-libgpg-error alsa-plugins lib32-alsa-plugins alsa-lib lib32-alsa-lib libjpeg-turbo lib32-libjpeg-turbo sqlite lib32-sqlite libxcomposite lib32-libxcomposite libxinerama lib32-libgcrypt libgcrypt lib32-libxinerama ncurses lib32-ncurses opencl-icd-loader lib32-opencl-icd-loader libxslt lib32-libxslt libva lib32-libva gtk3 lib32-gtk3 gst-plugins-base-libs lib32-gst-plugins-base-libs vulkan-icd-loader lib32-vulkan-icd-loader

To enable ACO i just created a .pam_environment file in my home folder with this inside:

You can verify that ACO is on by starting steam from the command line and looking for the line similar to caution…there be dragons here.

I am not sure if you did all of these steps but in case not, it might help.

1 Like

so you ask to add multilib for support drivers amdgpu ?

You will need multilib for gaming, for me the repository for it was already enabled. I just needed to add all the packages.

Hello @I0F
First of all what desktop are you using on EOS with the RX 5700? What have you done since installing EOS?

inxi -Fxxxza --no-host

Today I finally found some time to try your suggestion and it worked. Thank you very much.


I couldn’t be more surprised. You’re welcome. :slight_smile: