Problems updating kernel-lts repo

After rebooting my system after a successful update, I ran a quick checkupdates to make sure I was really up-to-date. It threw an error: ERROR: Cannot fetch updates, so I tried it as root and got the same message. Thinking that maybe the database was screwed up, I tried running yay -Dk, then yay -Syu:

yay -Dk
No database errors have been found!

yay -Syu
:: Synchronizing package databases...
 core                                                                                                            138.4 KiB   423 KiB/s 00:00 [--------------------------------------------------------------------------------------] 100%
 extra                                                                                                          1555.6 KiB  2.52 MiB/s 00:01 [--------------------------------------------------------------------------------------] 100%
 community                                                                                                         6.0 MiB  9.68 MiB/s 00:01 [--------------------------------------------------------------------------------------] 100%
 multilib is up to date
 endeavouros is up to date
 kernel-lts.db failed to download
 chaotic-aur                                                                                                    1758.3 KiB  2.02 MiB/s 00:01 [--------------------------------------------------------------------------------------] 100%
error: failed retrieving file 'kernel-lts.db' from : error:1408F10B:SSL routines:ssl3_get_record:wrong version number
error: failed to synchronize all databases (unexpected error)
 -> error installing repo packages

Pinging the server works.

:: Synchronizing package databases...
core                                   138.4 KiB  76.5 KiB/s 00:02 [--------------------------------------] 100%
extra                                 1555.7 KiB   558 KiB/s 00:03 [--------------------------------------] 100%
community                                6.0 MiB  1780 KiB/s 00:03 [--------------------------------------] 100%
multilib                               148.9 KiB  80.7 KiB/s 00:02 [--------------------------------------] 100%
endeavouros                             24.2 KiB  15.6 KiB/s 00:02 [--------------------------------------] 100%
kernel-lts                              33.7 KiB  17.6 KiB/s 00:02 [--------------------------------------] 100%

No issue here.

How are you connecting to the repo … VPN or ISP?

ISP. I’ve been using this repo for about 2 weeks now and haven’t had any issues until this afternoon. What’s weird is that my full system update (ran this morning) updated the 5.10-LTS kernel without a hitch.

Pinging the maintainer of the AUR kernel-lts may help. To the rescue @jonathon ?

I wonder if updating the archlinux-keyring has anything to do with this. I don’t believe my internet connection has any effect, although the ping I ran was slow.

Nah, this is an SSL / TLS error, usually triggered when attempting to retrieve an https connection with http.

Try with a VPN connection if you can , not your ISP.

1 Like

Same error message.

What changed in that update?

Here’s the transaction log:

[2022-01-28T09:04:33-0800] [PACMAN] Running 'pacman -S --config /etc/pacman.conf -- aspell'
[2022-01-28T09:04:35-0800] [ALPM] running '05-snap-pac-pre.hook'...
[2022-01-28T09:04:35-0800] [ALPM-SCRIPTLET] ==> root: 942
[2022-01-28T09:04:35-0800] [ALPM] transaction started
[2022-01-28T09:04:35-0800] [ALPM] installed aspell (0.60.8-2)
[2022-01-28T09:04:36-0800] [ALPM] transaction completed
[2022-01-28T09:04:36-0800] [ALPM] running '30-systemd-update.hook'...
[2022-01-28T09:04:36-0800] [ALPM] running 'texinfo-install.hook'...
[2022-01-28T09:04:36-0800] [ALPM] running 'zz-snap-pac-post.hook'...
[2022-01-28T09:04:36-0800] [ALPM-SCRIPTLET] ==> root: 943
[2022-01-28T09:09:54-0800] [PACMAN] Running 'pacman -S -y -u --config /etc/pacman.conf --'
[2022-01-28T09:09:54-0800] [PACMAN] synchronizing package lists
[2022-01-28T09:09:56-0800] [PACMAN] starting full system upgrade
[2022-01-28T09:10:59-0800] [ALPM] running '05-snap-pac-pre.hook'...
[2022-01-28T09:10:59-0800] [ALPM-SCRIPTLET] ==> root: 944
[2022-01-28T09:10:59-0800] [ALPM] running '60-mkinitcpio-remove.hook'...
[2022-01-28T09:10:59-0800] [ALPM] running '71-dkms-remove.hook'...
[2022-01-28T09:10:59-0800] [ALPM-SCRIPTLET] ==> dkms remove --no-depmod nvidia/470.94 -k 5.10.93-1-lts510
[2022-01-28T09:11:00-0800] [ALPM-SCRIPTLET] ==> dkms remove --no-depmod vmware-workstation/16.2.1_18811642 -k 5.10.93-1-lts510
[2022-01-28T09:11:00-0800] [ALPM-SCRIPTLET] ==> dkms remove --no-depmod nvidia/470.94 -k 5.15.16-1-lts
[2022-01-28T09:11:00-0800] [ALPM-SCRIPTLET] ==> dkms remove --no-depmod vmware-workstation/16.2.1_18811642 -k 5.15.16-1-lts
[2022-01-28T09:11:01-0800] [ALPM-SCRIPTLET] ==> depmod 5.10.93-1-lts510
[2022-01-28T09:11:06-0800] [ALPM-SCRIPTLET] ==> depmod 5.15.16-1-lts
[2022-01-28T09:11:09-0800] [ALPM] transaction started
[2022-01-28T09:11:09-0800] [ALPM] upgraded alsa-card-profiles (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-28T09:11:09-0800] [ALPM] upgraded archlinux-keyring (20220118-1 -> 20220125-1)
[2022-01-28T09:11:09-0800] [ALPM-SCRIPTLET] ==> Appending keys from archlinux.gpg...
[2022-01-28T09:11:11-0800] [ALPM-SCRIPTLET] ==> Updating trust database...
[2022-01-28T09:11:11-0800] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2022-05-06
[2022-01-28T09:11:11-0800] [ALPM-SCRIPTLET] ==> Updating trust database...
[2022-01-28T09:11:11-0800] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2022-05-06
[2022-01-28T09:11:11-0800] [ALPM] installed oniguruma (
[2022-01-28T09:11:11-0800] [ALPM] upgraded bat (0.18.3-1 -> 0.19.0-1)
[2022-01-28T09:11:12-0800] [ALPM] upgraded candy-icons-git (r758.b1a79d8-1 -> r768.45719cd-1)
[2022-01-28T09:11:12-0800] [ALPM] upgraded util-linux-libs (2.37.2-5 -> 2.37.3-1)
[2022-01-28T09:11:12-0800] [ALPM] upgraded libcap (2.62-1 -> 2.63-1)
[2022-01-28T09:11:12-0800] [ALPM] upgraded cmake (3.22.1-5 -> 3.22.2-1)
[2022-01-28T09:11:13-0800] [ALPM] installed fzf (0.29.0-1)
[2022-01-28T09:11:13-0800] [ALPM] upgraded util-linux (2.37.2-5 -> 2.37.3-1)
[2022-01-28T09:11:13-0800] [ALPM] upgraded glib2 (2.70.2-2 -> 2.70.3-1)
[2022-01-28T09:11:13-0800] [ALPM] upgraded downgrade (10.1.1-1 -> 11.0.0-1)
[2022-01-28T09:11:13-0800] [ALPM] upgraded ell (0.47-1 -> 0.48-1)
[2022-01-28T09:11:13-0800] [ALPM] upgraded ethtool (1:5.15-1 -> 1:5.16-1)
[2022-01-28T09:11:13-0800] [ALPM] upgraded faac (1.30-2 -> 1.30-3)
[2022-01-28T09:11:13-0800] [ALPM] upgraded mesa (21.3.4-1 -> 21.3.5-1)
[2022-01-28T09:11:13-0800] [ALPM] upgraded xf86-input-libinput (1.2.0-2 -> 1.2.1-1)
[2022-01-28T09:11:13-0800] [ALPM] upgraded fluidsynth (2.2.4-1 -> 2.2.5-1)
[2022-01-28T09:11:13-0800] [ALPM] upgraded geoip-database (20211221-1 -> 20220125-1)
[2022-01-28T09:11:13-0800] [ALPM] upgraded git (2.34.1-1 -> 2.35.0-1)
[2022-01-28T09:11:13-0800] [ALPM] upgraded gnome-terminal-transparency (3.42.1-1 -> 3.42.2-1)
[2022-01-28T09:11:14-0800] [ALPM] upgraded pipewire (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-28T09:11:14-0800] [ALPM] upgraded gst-plugin-pipewire (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-28T09:11:14-0800] [ALPM] upgraded imagemagick ( ->
[2022-01-28T09:11:14-0800] [ALPM] upgraded iwd (1.21-1 -> 1.23-1)
[2022-01-28T09:11:14-0800] [ALPM] upgraded js78 (78.15.0-2 -> 78.15.0-3)
[2022-01-28T09:11:14-0800] [ALPM] upgraded lib32-libldap (2.6.0-1 -> 2.6.1-1)
[2022-01-28T09:11:15-0800] [ALPM] upgraded lib32-mesa (21.3.4-1 -> 21.3.5-1)
[2022-01-28T09:11:15-0800] [ALPM] upgraded libbsd (0.11.4-1 -> 0.11.5-1)
[2022-01-28T09:11:15-0800] [ALPM] upgraded libunrar (1:6.1.3-1 -> 1:6.1.4-1)
[2022-01-28T09:11:15-0800] [ALPM] upgraded licenses (20200427-1 -> 20220125-1)
[2022-01-28T09:11:16-0800] [ALPM] upgraded linux-lts (5.15.16-1 -> 5.15.17-1)
[2022-01-28T09:11:18-0800] [ALPM] upgraded linux-lts-headers (5.15.16-1 -> 5.15.17-1)
[2022-01-28T09:11:19-0800] [ALPM] upgraded linux-lts510 (5.10.93-1 -> 5.10.94-1)
[2022-01-28T09:11:22-0800] [ALPM] upgraded linux-lts510-headers (5.10.93-1 -> 5.10.94-1)
[2022-01-28T09:11:22-0800] [ALPM] upgraded lua (5.4.3-1 -> 5.4.4-1)
[2022-01-28T09:11:22-0800] [ALPM] upgraded openexr (3.1.3-1 -> 3.1.4-1)
[2022-01-28T09:11:23-0800] [ALPM] upgraded perl-io-socket-ssl (2.073-1 -> 2.074-1)
[2022-01-28T09:11:23-0800] [ALPM] upgraded polkit (0.120-3 -> 0.120-4)
[2022-01-28T09:11:23-0800] [ALPM] upgraded python-dnspython (1:2.1.0-3 -> 1:2.2.0-1)
[2022-01-28T09:11:23-0800] [ALPM] upgraded python-fonttools (4.28.5-1 -> 4.29.0-1)
[2022-01-28T09:11:23-0800] [ALPM] upgraded qt5-base (5.15.2+kde+r294-1 -> 5.15.2+kde+r295-1)
[2022-01-28T09:11:23-0800] [ALPM] upgraded qt5-wayland (5.15.2+kde+r44-1 -> 5.15.2+kde+r46-1)
[2022-01-28T09:11:23-0800] [ALPM] upgraded rubberband (2.0.1-1 -> 2.0.2-1)
[2022-01-28T09:11:24-0800] [ALPM] upgraded sane (1.0.32-3 -> 1.1.1-1)
[2022-01-28T09:11:24-0800] [ALPM] upgraded vulkan-headers (1:1.2.203-1 -> 1:1.3.204-1)
[2022-01-28T09:11:24-0800] [ALPM] upgraded wpa_supplicant (2:2.9-8 -> 2:2.10-1)
[2022-01-28T09:11:24-0800] [ALPM] upgraded xl2tpd (1.3.16-1 -> 1.3.17-1)
[2022-01-28T09:11:24-0800] [ALPM] transaction completed

From the kernel-lts repo, the 5.10 kernel was updated to v5.10.94-1.

Works om my end as well (VPN)

$ yay -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community                         6.0 MiB  4.85 MiB/s 00:01 [################################] 100%
 multilib is up to date
 endeavouros is up to date
 kernel-lts is up to date

Hopefully @jonathon can help; really don’t know what to try next. I guess I could purge the repo and remove all the relevant files and start over. But I’ll wait for now.

Thanks for everyone’s input.

Whenever I’ve has similar SSL / TLS issues (ie curl download errors), they’ve been related to specific VPN exit nodes, config or maintenace changes which were fixed by the VPN provider (eventually).

I just used different exit nodes and / or different VPN providers as a workaround.

Are you using a wireless connection?

There have been issues with wpa_supplicant lastest version, you could try downgrading that and see if it helps.

1 Like

DM me your IP address and I’ll check the server logs.

1 Like



1 Like

Don’t even have a WiFi adapter installed; VPN is rarely used.

OK, the last time I see your IP address was the 26th January (pacman checking for changes in the database). This is weird if you updated on 28th Jan., possibly suggests a change in your networking.

Can you check you are resolving the correct IP for the server (, and that you can access it via a web browser?

$ nslookup

Non-authoritative answer:
Address: 2001:41d0:a:14ce::1

I can’t access the site via (ungoogled) chromium:

# This site can’t provide a secure connection

**** sent an invalid response.


Using https:// prefix?

I can’t switch to http; regardless of the settings I disable, it always switches to https.

Aahh, switched to Tor and it works, so at least I know the site is reachable. I’ve also tried switching to my ISP’s DNS, but it made no difference.

Before I start poking around on the server (also considering this is the first time someone has said there’s an issue) could you try accessing via a browser using an EnOS (or any) live installer environment to rule out changes to the local OS?