Problems in Pipewire and Easy Effect

Hi. Last night I tried to install Easy Effects. The problem is that the audio is late for a few seconds (sometimes it can be 10 seconds). And sometimes CPU usage goes up with some filters activated. this is the result in inxi -A
[renosp@reno-satellitel645 ~]$ inxi -A
Audio:
Device-1: Intel 5 Series/3400 Series High Definition Audio
driver: snd_hda_intel
Sound Server-1: ALSA v: k5.17.9-arch1-1 running: yes
Sound Server-2: PipeWire v: 0.3.51 running: yes
[renosp@reno-satellitel645 ~]$

After I uninstalled the sound returned to normal and had no intention of using Easy Effects again.

Did you setup your latencies in pipewire? If CPU usage went up likely Pipewire attempted to ensure playback continued so latency went through the roof.

What FX did you use?

I didn’t set the Pipewire latency until now. Still the default setting. I haven’t used any Sound Effects yet.

try it after getting your latencies setup, take a look at the piepwire documentation here

## Properties for the DSP configuration.
    #default.clock.rate          = 48000
    #default.clock.allowed-rates = [ 48000 ]
    #default.clock.quantum       = 1024
    default.clock.min-quantum   = 16
    #default.clock.max-quantum   = 2048
    #default.clock.quantum-limit = 8192

This stuff here is going to be primarily what youre looking to tweak to prevent that issue.

That seems to solve my problem with Easyeffects and pipewire. I just need to adjust the sound effects that fit what I need.
Thanks.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.