Problems booting atfer use another OS (ssd)

Hello All :slight_smile:

I have installed EOS which Im still amazed :crazy_face: :sunglasses: :person_raising_hand: :sweat_smile: :heart_eyes_cat: :yum:

I had to use my old OS (ubuntu) which is very handy since i have another SSD with it… Just need to change SSD and we are good.

Problem is … when I return to EOS not sure why bios do not detect any HDD/SSD .

To “solve” this, I need to use manjaro installation media (pendrive) and pick the Detect UEFI Booloaders option. After that pc returns to EOS Grub and conitnue normally.

This will not fix bios. Each time i want to use EOS I need to repeat the process.
Any clue why this happens?
WIth my old SDD (ubuntu) no problem at all.

WIsh u all a great day :slight_smile:

This happens most probably due to update to Ubuntu’s Grub.
If I remember it correctly, whenever there is such, it put itself on top of the boot priority.

From within your EnOS run:

efibootmgr -v

to check the boot order.

You could use the same command line tool to change the boot order.

1 Like

Edit:
Is the other OS installed in Bios mode? Not sure if you mean you have Ubuntu on another drive and booted it and used it and then it doesn’t boot EOS?

Edit2: Is the other SSD an external usb drive or is internal?

Edit3: Try as @pebcak posted above and see what the output shows.

Hello @pebcak and ty for the help :slight_smile:

efibootmgr -v

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002
Boot0002* endeavouros-8864      HD(1,GPT,9e92a3c4-11a2-4945-8ba9-e3fe80a82d22,0x22,0x967de)/File(\EFI\endeavouros-8864\grubx64.efi)

I had to create 2 partitions in order to install EOS. One for UEFI Boot the other (main) for EOS.

1 Like

You have only one UEFI boot entry.
This could mean that your Ubuntu might be installed in Bios mode as mentioned above by @ricklinux.

With your Ubuntu disk attached, run:

sudo parted -l

and post the output.

Hello @ricklinux once again ty for the support :slight_smile:

Is the other OS installed in Bios mode? Not sure if you mean you have Ubuntu on another drive and booted it and used it and then it doesn’t boot EOS?
Edit2: Is the other SSD an external usb drive or is internal?

I have 2 ssd’s (both internal. 120 giga each) One has Ubuntu the other EOS.

If I need to use Ubuntu OS I just need to change ssd and use Ubuntu’s ssd.
Problem starts as soon I change ssd to EOS. Bios do not detect ssd.

To “fix this” (in otder to boot to EOS) I have to use Manjaro installation media (pendrive) and pick the Detect UEFI Booloaders option. After that PC returns to EOS Grub and conitnue normally.

But have to do this each time I want to use EOS .

Any clue ?

@pebcak maybe I didnt explain myself. Sorry lol
Do please read the message I sent to @ricklinux :slight_smile:

Thanks :slight_smile:

Okay so when you can boot into EOS does the grub menu have both EOS and Ubuntu listed? Are you able to enter Ubuntu from there?

What if you brought up Bios’ one time boot menu?

You should be able to choose EnOS or Ubuntu from there no matter which mode they are installed in.

But anyways, it does sound a bit strange that after booting Ubuntu, Bios won’t recognize your EnOS.

Would still be good to know if Ubuntu is installed in Legacy/MBR or UEFI mode:

sudo parted -l

Okay so when you can boot into EOS does the grub menu have both EOS and Ubuntu listed? Are you able to enter Ubuntu from there?

2 discs Lol

After i change Ubuntu ssd with EOS ssd. Bios dont recognize ssd. The only option i have is to boot from Manjaro installation media (pendrive) and pick the Detect UEFI Booloaders option. After that i get the EOS grub menu I need to to this everytime i want to boot with EOS ssd.

You should be able to choose EnOS or Ubuntu from there no matter which mode they are installed in.

I would if there was 1 ssd with 2 partitions (EOS+Ubuntu)

In this case is 2 ssd’s with 2 partitions (on one ssd EOS and the other SSD EOS).

sudo parted -l

Number  Start   End    Size   File system  Name  Flags
 1      17,4kB  316MB  316MB  fat32              boot, esp
 2      316MB   120GB  120GB  btrfs

Thats my EOS ssd. RIght now all good BECAUSE I DIDNT REMOVE IT YET LOL as soon i swap discs (EOS for UBUNTU and back TO EOS) i will not be able to boot in a normal way. Just using Manjaro installation media (pendrive) and pick the Detect UEFI Booloaders option. After that i get the EOS grub menu I need to to this everytime i want to boot with EOS ssd.

This is not the whole output!

We need to know your exact disk set up to be able to offer some help.

I realize you have two discs. What I’m asking is how you are switching to Ubuntu in the first place. Does the grub menu have both Ubuntu and EOS in it to select which OS to boot or are you entering the Bios and changing the boot order or via an F key to switch?

If you are booted in EOS give the output link to

cat /etc/default/grub | eos-sendlog
 % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2331    0    24  100  2307     37   3567 --:--:-- --:--:-- --:--:--  3602
https://clbin.com/RYzAL

What does the output show if you update grub on eos.

sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
done

I realize you have two discs. What I’m asking is how you are switching to Ubuntu in the first place. Does the grub menu have both Ubuntu and EOS in it to select which OS to boot or are you entering the Bios and changing the boot order or via an F key to switch?

The switch is manually. I just remove one disc and insert the other one. Then I just need to go to bios and set the right order if needed.

I would suspect that Ubuntu is installed in Bios mode. You can use gparted and select the other drive from the drop down menu that Ubuntu is installed on and post an image of it.

They swap the disks physically I gather.