Problem with write access on Windows partition

Hi guys,

I would appreciate any help if possible.

I have a Windows partition here (NTFS), and it is being mounted automatically through /etc/fstab.

There I added the following:

/dev/sda6 /home/user/Partition_Name                  ntfs    defaults,noatime,rw,users,permissions,uid=user,gid=group 0 0

Well, despite that, I still don´t getting to place files there, always . I also checked and, for example, everything seems to be OK, files and folders belonging to my user and group, with read and write permissions, etc.

Also, restic does frequent automatic backups from there, without any problems.

Anyone has some idea about where’s the problem?

Thanks.

You might want to have a read at the following article and see if it helps you to resolve your issue:

https://wiki.archlinux.org/title/NTFS-3G

Try using ntfs3 instead of ntfs

Also, make sure you have disabled “Fast Startup” in Windows. If you don’t, the drive will always be marked dirty and mounted read-only.

Thanks, guys. I’ll check these things. :wink:

2 Likes

Old post, but still …

How to automount windows ntfs partition with linux compatible permissions…

Great, many thanks. I’ll take a look.