Problem with WLAN on HP ProBook 455 G1 after new Installation

I installed EOS Xfce for the first time today on an HP ProBook 455 G1 (got the machine as a gift a few days ago). However, the WLAN can not be activated or connected. Can this have to do with the FirewallD, what can I do?

[uwe@HALhp ~]$ inxi -Fxxc0z --no-host | eos-sendlog
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  4083    0    24  100  4059     34   5877 --:--:-- --:--:-- --:--:--  5917
https://clbin.com/ICMd6
[uwe@HALhp ~]$ journalctl -b -0 | eos-sendlog
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233k    0    24  100  233k     16   159k  0:00:01  0:00:01 --:--:--  159k
https://clbin.com/cDtxF
[uwe@HALhp ~]$ 
1 Like

I could spot the following:

Mai 18 19:05:02 HALhp wpa_supplicant[450]: rfkill: WLAN soft blocked
Mai 18 19:05:02 HALhp NetworkManager[376]: [1652893502.4339] device (wlan0): supplicant interface state: disconnected → interface_disabled

which might be the issue.

What is the output from

rfkill list

?

And then…

  1. $ sudo systemctl start pipewire.service
  2. $ sudo systemctl enable pipewire.service

Then, there are errors in your drives / partitioning.

Please, post your output of $ sudo blkid, and check your fstab-file in /etc/fstab and post the contents here.

§ sudo nano /etc/fstab

There might actually be hardware-errors on your sdb-drive(!), as far as I can tell, too:

Maybe, someone else can weigh in @pebcak ?!

1 Like
pipewire.service not found

:dizzy_face:

[uwe@HALhp ~]$ rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
[uwe@HALhp ~]$ sudo blkid
[sudo] Passwort für uwe: 
/dev/sdb1: LABEL="Daten_UR" UUID="16aecd12-1755-4636-bcbe-1a88ba1a57d9" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="8252ff22-8ee8-de4c-ac1d-de819d9c7462"
/dev/sda4: LABEL="home" UUID="1c5b08e7-8278-41a2-9a3e-8142a29e5aab" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="0de25d2a-5d01-4985-96c6-2382206868aa"
/dev/sda2: LABEL="root" UUID="e6442f77-6c85-4358-8147-a84937fdcb0a" BLOCK_SIZE="1024" TYPE="ext4" PARTUUID="c090eb3e-909b-4b1a-b3f0-1400c4b2c6f0"
/dev/sda3: LABEL="swap" UUID="ced66a9f-df3f-441b-b2f2-4d51d3064d05" TYPE="swap" PARTUUID="36972cee-1ec0-4c3c-9b72-f1946c9df4f3"
/dev/sda1: LABEL_FATBOOT="BOOT-EFI" LABEL="BOOT-EFI" UUID="F2BD-D3D3" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="11c5d562-5f71-416f-bf27-95677aaf189d"
[uwe@HALhp ~]$ 
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=F2BD-D3D3                            /boot/efi      vfat    defaults,noatime 0 2
UUID=e6442f77-6c85-4358-8147-a84937fdcb0a /              ext4    defaults,noatime 0 1
UUID=1c5b08e7-8278-41a2-9a3e-8142a29e5aab /home          ext4    defaults,noatime 0 2
tmpfs               
1 Like

rfkill: WLAN soft blocked

Your logs must be pulling our leg!
:sweat_smile:

Device-2: Ralink RT3290 Wireless 802.11n 1T/1R PCIe
vendor: Hewlett-Packard driver: rt2800pci v: 2.3.0 pcie: speed: 2.5 GT/s
lanes: 1 bus-ID: 03:00.0 chip-ID: 1814:3290

Could be a driver issue. You might want to give the following package in AUR a try:

https://aur.archlinux.org/packages/rt3290sta-dkms

Install and reboot and see if it works.

1 Like

Pipewire uses systemd/User for management of the server and automatic socket activation.

You might want to have a look here.

1 Like

Then, pipewire isn’t yet installed correctly. Do:

§ sudo pacman -Syu
$ sudo pacman -S --needed pipewire pipewire-pulse pipewire-alsa wireplumber pipewire-media-session pipewire-jack

wireplumber / pipewire-media-session can only be installed either / or.

After re-installing, try to start & enable pipewire.service like above.

If you refer to these:

Those won’t work. See:

2 Likes

Oops, you mean systemd isn’t installed on his machine?

Well, then I’m completely off-topic here…?

:mobile_phone_off:

Wait … this is a complete reinstallation of EOS!

No!
Of course it is installed.

Please refer to

https://wiki.archlinux.org/title/Systemd/User

systemd offers the ability to manage services under the user’s control with a per-user systemd instance, enabling them to start, stop, enable, and disable their own user units. This is convenient for daemons and other services that are commonly run for a single user, such as mpd, or to perform automated tasks like fetching mail.

This is what is used by pipewire.

These are the relevant files installed on the system:

pipewire /usr/lib/systemd/user/
pipewire /usr/lib/systemd/user/pipewire.service
pipewire /usr/lib/systemd/user/pipewire.socket

1 Like

Sorry I was being confused (and thank you).

1 Like

I guess you have to expound more, for us newbies…

Failed to enable unit: Unit file pipewire.service does not exist. :hot_face:

What commands did you run?

sudo systemctl start pipewire.service
sudo systemctl enable pipewire.service 

This is really a bit of-topic regarding the issue at hand.

Please read the links I have posted and if something is not clear, open a thread for discussion aronud:

“system-wide” systemd services VS per user systemd services.

I wrote above that those won’t work and gave the reason for it.

If you want to get your wifi working, I gave you the indication what to do.

1 Like