Problem with updating

Hi all, when I run the Endeavour updater it tells me I need to update but then doesn’t complete the update.
I get this message: error: failed to synchronize all databases (unable to lock database)

I tried this: sudo rm /var/lib/pacman/db.lck but I get the message which says it doesn’t exist.
Any ideas?

Can we see the full output?

Just reading the forum bit on how to do that, back soon :+1:

You can just copy the text and paste it into the forum.

Then put 3 tildes


Above and below the output.

Arch & EndeavourOS update check:
:: Searching Arch & EndeavourOS for updates...
downgrade 10.1.0-1 -> 10.1.1-1
Root Password: 
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 endeavouros is up to date

There are no errors there.

Can you share the output of:

sudo pacman -Syu
1 Like

I ran that and it updated perfectly. It just wouldn’t when I used the update in terminal. Ah well all good :smiley:

Never underestimate how little I know about what I’m doing. :joy:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.