Problem With Pulseaudio

I reinstall EnOS yesterday on my laptop and found out today that plugging in my headphone does not change the out put device . The device is listed in pavucontrol . But it shows the headphone is unplugged all the time , i.e. if it’s plugged in or not pavucontrol shows it’s unplugged . I can manually switch the output to headphone . Then headphone will work . But when I unplug it the audio is not switched to speakers . I have to do it manually .

System specs

Intel Pentium 4417u
4 GB RAM
Kernel 5.9.14-arch-1
XFCE DE

These two screenshots were taken when the headphone was not plugged in

alsamixer

pavucontrol

Plugging in the headphone does not make any difference to these screenshots :man_shrugging:
Also I noticed gwenview is listed in xfce4-pulseaudio-plugin though I never played a video in gwenview . I have seen some posts about an extra loopback in pulseaudio in some forums but not any issue like this :no_mouth:

Do you by any chance have a line-out option in output devices? I found this and seemed quite like your issue https://www.ghacks.net/2019/08/13/fix-for-no-sound-issue-on-linux-when-using-headphones/

The problem is same but it’s not a solution . He is just sticking with the default output and don’t plan to change the device . That’s not the case with my laptop , I have to use it with headphones and speakers and changing the device manually every time is not a good option :man_shrugging:

do you have this inside your: /etc/pulse/default.pa ?

# automatically switch to newly-connected devices 
load-module module-switch-on-connect

2 Likes

It didn’t . So I added them and it doesn’t seem to change anything :man_shrugging:

Am I missing something

already try to reset pulse for your user?
mv ~/.config/pulse ~/.config/old-pulse
and issue could be also on alsa level, something like Auto-Mute Mode is enabled inside alsamixer?

this fix my audio problems … lot of times … he a star :pray:

2 Likes

i am still workingon that wiki it needs some commands and info on pulseaudio to nail down issues more easy…

2 Likes

it great … my go for audio problem

pacmd - Reconfigure a PulseAudio sound server during runtime

pacmd --help
pacmd exit
pacmd help
pacmd list-(modules|sinks|sources|clients|cards|samples)
pacmd list-(sink-inputs|source-outputs)
pacmd stat
pacmd info
pacmd load-module NAME [ARGS ...]
pacmd unload-module NAME|#N
pacmd describe-module NAME
pacmd set-(sink|source)-volume NAME|#N VOLUME
pacmd set-(sink-input|source-output)-volume #N VOLUME
pacmd set-(sink|source)-mute NAME|#N 1|0
pacmd set-(sink-input|source-output)-mute #N 1|0
pacmd update-(sink|source)-proplist NAME|#N KEY=VALUE
pacmd update-(sink-input|source-output)-proplist #N KEY=VALUE
pacmd set-default-(sink|source) NAME|#N
pacmd kill-(client|sink-input|source-output) #N
pacmd play-sample NAME SINK|#N
pacmd remove-sample NAME
pacmd load-sample NAME FILENAME
pacmd load-sample-lazy NAME FILENAME
pacmd load-sample-dir-lazy PATHNAME
pacmd play-file FILENAME SINK|#N
pacmd dump
pacmd move-(sink-input|source-output) #N SINK|SOURCE
pacmd suspend-(sink|source) NAME|#N 1|0
pacmd suspend 1|0
pacmd set-card-profile CARD PROFILE
pacmd set-(sink|source)-port NAME|#N PORT
pacmd set-port-latency-offset CARD-NAME|CARD-#N PORT OFFSET
pacmd set-log-target TARGET
pacmd set-log-level NUMERIC-LEVEL
pacmd set-log-meta 1|0
pacmd set-log-time 1|0
pacmd set-log-backtrace FRAMES

  -h, --help                            Show this help
      --version                         Show version
When no command is given pacmd starts in the interactive mode.
pacmd list-sinks

will show info about connected output-input-devices

1 Like

I disabled it and no effect .

Will try this out now !

systemctl --user restart pulseaudio.socket

after moving configs out of the way should be good to go, but a reboot will do also…

Did a reboot but no luck . The problem persists . Along with a new one , there is an Unplugged Headphone listed in input section . Just noticed it now . The problem is not that the device is not recognized . Rather the device is shown as Unplugged when it’s plugged in . It shouldn’t even be there on the list when unplugged , but still is there (as unplugged headphone) and the microphone too .

pacmd list-sinks

1 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 9039
	volume: front-left: 30129 /  46% / -20.25 dB,   front-right: 30129 /  46% / -20.25 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max request: 0 KiB
	max rewind: 0 KiB
	monitor source: 0
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 6
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC255 Analog"
		alsa.id = "ALC255 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xb1320000 irq 132"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "9d71"
		device.product.name = "Sunrise Point-LP HD Audio"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-speaker>

What is your hardware? inxi -Fxxxa --no-host

Maybe this helps.

could you try while watching journal to plugin the headphone?
journalctl -f in a term and then plugin the headphone, and copy paste what it shows.

journalctl -f
-- Journal begins at Sat 2020-12-19 21:48:37 IST. --
Dec 19 23:04:11 ame-pc kernel: pcieport 0000:00:1c.0:   device [8086:9d14] error status/mask=00003000/00002000
Dec 19 23:04:11 ame-pc kernel: pcieport 0000:00:1c.0:    [12] Timeout               
Dec 19 23:04:43 ame-pc kernel: pcieport 0000:00:1c.0: AER: Corrected error received: 0000:00:1c.0
Dec 19 23:04:43 ame-pc kernel: pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
Dec 19 23:04:43 ame-pc kernel: pcieport 0000:00:1c.0:   device [8086:9d14] error status/mask=00003000/00002000
Dec 19 23:04:43 ame-pc kernel: pcieport 0000:00:1c.0:    [12] Timeout               
Dec 19 23:04:53 ame-pc kernel: pcieport 0000:00:1c.0: AER: Corrected error received: 0000:00:1c.0
Dec 19 23:04:53 ame-pc kernel: pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
Dec 19 23:04:53 ame-pc kernel: pcieport 0000:00:1c.0:   device [8086:9d14] error status/mask=00001000/00002000
Dec 19 23:04:53 ame-pc kernel: pcieport 0000:00:1c.0:    [12] Timeout               
Dec 19 23:05:47 ame-pc kernel: pcieport 0000:00:1c.0: AER: Corrected error received: 0000:00:1c.0
Dec 19 23:05:47 ame-pc kernel: pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
Dec 19 23:05:47 ame-pc kernel: pcieport 0000:00:1c.0:   device [8086:9d14] error status/mask=00003000/00002000
Dec 19 23:05:47 ame-pc kernel: pcieport 0000:00:1c.0:    [12] Timeout

When I tried to find the line

[Jack Headphone]
state.plugged = no
state.unplugged = unknown

in /usr/share/pulseaudio/alsa-mixer/paths/analog-output-lineout.conf
I found out that there is no /usr/share/pulseaudio folder .
Is that a problem ??

`inxi -Fxxxa --no-host

System:    Kernel: 5.9.14-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux root=UUID=5696a235-4f76-4e3b-8059-f93c78a448fe rw 
           rootflags=subvol=@ quiet 
           cryptdevice=UUID=6445586c-3f13-4865-82bd-6a98ba1040d3:luks-6445586c-3f13-4865-82bd-6a98ba1040d3 
           root=/dev/mapper/luks-6445586c-3f13-4865-82bd-6a98ba1040d3 loglevel=3 nowatchdog 
           Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: EndeavourOS 
Machine:   Type: Laptop System: Acer product: Aspire A315-53 v: V2.02 serial: <superuser required> 
           Mobo: KBL model: Metapod_KL v: V2.02 serial: <superuser required> UEFI: Insyde v: 2.02 date: 01/03/2019 
Battery:   ID-1: BAT1 charge: 19.1 Wh condition: 24.7/37.0 Wh (67%) volts: 7.8/7.7 model: PANASONIC 004A354D36315041 
           type: Li-ion serial: 0000 status: Discharging 
CPU:       Info: Dual Core model: Intel Pentium 4417U bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6 
           model-id: 8E (142) stepping: A (10) microcode: E0 L2 cache: 2 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18406 
           Speed: 800 MHz min/max: 400/2300 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5906 
           Device-2: Quanta VGA WebCam type: USB driver: uvcvideo bus ID: 1-7:4 chip ID: 0408:a031 serial: 0x0001 
           Display: x11 server: X.org 1.20.10 driver: intel unloaded: fbdev,modesetting,vesa 
           resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.9.14-arch1-1 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI 
           driver: r8168 v: 8.048.03-NAPI modules: r8169 port: 3000 bus ID: 01:00.1 chip ID: 10ec:8168 
           IF: enp1s0f1 state: down mac: 98:28:a6:41:29:ff 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On driver: ath10k_pci 
           v: kernel port: 3000 bus ID: 02:00.0 chip ID: 168c:0042 
           IF: wlan0 state: up mac: f8:a2:d6:84:fa:69 
           Device-3: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb bus ID: 1-5:3 
           chip ID: 04ca:3015 
Drives:    Local Storage: total: 465.76 GiB used: 65.4 GiB (14.0%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: 29FXC12ZT rev: 2J 
Partition: ID-1: / raw size: 465.27 GiB size: 465.27 GiB (100.00%) used: 65.4 GiB (14.1%) fs: btrfs dev: /dev/dm-0 
           maj-min: 254:0 mapped: luks-6445586c-3f13-4865-82bd-6a98ba1040d3 
           ID-2: /boot/efi raw size: 500 MiB size: 499 MiB (99.80%) used: 696 KiB (0.1%) fs: vfat dev: /dev/sda1 
           maj-min: 8:1 
           ID-3: /home raw size: 465.27 GiB size: 465.27 GiB (100.00%) used: 65.4 GiB (14.1%) fs: btrfs 
           dev: /dev/dm-0 maj-min: 254:0 mapped: luks-6445586c-3f13-4865-82bd-6a98ba1040d3 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 1024 MiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 214 Uptime: 1h 31m wakeups: 2 Memory: 3.72 GiB used: 2.15 GiB (57.7%) Init: systemd v: 247 
           Compilers: gcc: 10.2.0 Packages: pacman: 1028 lib: 249 Shell: Bash v: 5.1.0 running in: xfce4-terminal 
           inxi: 3.2.00

is alsa-utils installed?
sudo alsactl restore could help
also check if it is related to kernel drivers from latest kernel may LTS one do not have this issue…

@Hystrix
Have you installed sof-firmware?

reboot required