Problem with plasma desktop

i’ve been having problems since i updated plasma desktop back to 27 october, since then whenever i login all i get is endeavour’s wallpaper and the mouse cursor, nothing else, right mouse click doesn’t work, tried the terminal shortcut but that didn’t work either, so i’ve been using xfce til i get that problem solved

Whenever you hit a DE specific problem like that I always recommend creating a new user account and trying to log in with it.

That will let you know if the issue is with the config/cache of the specific user or if it is a global problem with your install.


i have nvidia driver installed and it works just fine, everything works fine on xfce so i believe it might be something related to plasma desktop

Right, but you don’t know if it is something in config/cache of your user or something actually wrong with your plasma install.

That is what testing with a new user account does for you.

what’s the easiest way for creating a new user account ?

sudo useradd -m testusername
sudo passwd testusername

great, i can do that from xfce and just restart to try the new user right ??

Yes, you can do that.

Just tried it, same result with new user

Is your system fully up-to-date?


What is the output of:

cat /etc/pacman.conf /etc/pacman.d/* | grep -i ignore
[ramon@ramon-m61pmes2p ~]$ LANG=C cat /etc/pacman.conf /etc/pacman.d/* | grep -i ignore
cat: /etc/pacman.d/gnupg: Is a directory
cat: /etc/pacman.d/hooks: Is a directory
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =
[ramon@ramon-m61pmes2p ~]$ 

Try reinstalling plasma to ensure nothing is missing or corrupt. It shouldn’t hurt anything.

sudo pacman -Syu plasma

You can select “all” if it asks you what you want to install.

1 Like

is this valid for the plasma-meta package ? that’s normally how i get plasma installed

It shouldn’t hurt it. It will just re-install the packages in the group.

Unlike meta packages, groups don’t get installed. Only the individual packages in the group get installed. However, re-installing the meta-package will do nothing so there is no reason to do that.

This worked, thanks a lot !!


I’ve had the same problem.
After an update the plasma workspace was a dark hole, i discovered that the weather plugin i was using cause the issue. So I would suggested that if something similar happens in the future to remove the configuration file for the plasma panel and restart it.