Problem with blizzard games

I cant play all blizzard games that works from launcher, i tried install game normally and by using my prefix i install games from, i tried using ready prefix from lutris installer. Hearthstone start lagging randomly then its not playable and i need to force exit, hots is unplayable from begging it just stop working same with overwath dont even go through queue. I played without all this games on windows without problems so it means i have fucked up something. Also i have this problem only with games from blizzard. Also i tried to launch without and get same results

Have you checked this comprehensive awesome guide first?

Also if it would be a hardware/driver, no way for any of us to know what system you have and hence impossible to troubleshoot until you can post some useful information. Here how to do it…

Click on top of the forum >help>log tool and post your sys info link here.

I don’t use battle net so can’t comment that specific issue.

Assuming you’ve followed all the BattleNet steps on the Lutris wiki already / drivers are up to date / etc. I’ve recently had success with using caffe-7.18 in lutris to get Overwatch 2 working, might help with other Blizzard titles but I’m not certain since I don’t play Blizzard titles all that often.

Just manually throw this in ~/.local/share/lutris/runners/wine/ and restart lutris so you can select it as a wine version. Might notice stutters while the shaders rebuild, but otherwise I’ve had no stability issues on OW2 so far and I’ve been playing it for a couple of hours.

If you using the flatpak version of lutris the location is different /home/YOUR_USERNAME/.var/app/net.lutris.Lutris/data/lutris/runners/wine/.

Making OW2 working was a endeavour :laughing: of 3/4 hours with a lots of Kwin crash or global crash (thanks the :frog: @Kresimir for is tutorial on reisub)

What worked for me is :

  1. re-installing with lutris
  2. Start Bnet, disabling hardware accel in the config then downloading OW2
  3. Quit Bnet
  4. Change the runner with caffe-7.18
  5. Restart Bnet and pray

thanks actually now i can launch ow2, hs dont launch didnt tried hots. But i have really low fps dunno why 1 was working not perfect but stable.

Some people on the lutris discord have better performance when disabling Esync and/or Fsync. Caffe 7.18 didn’t support Fsync but some say that help so idk.

Idk why but when i click on that i have 0 reaction or just click what was behind panel i mean log