Problem with APU graphics in Civilization 6

I wasn’t sure whether to post this in hardware or gaming. I have a relatively new PC, but only have APU graphics. Everything has mostly been fine and I have managed to get Steam installed and a couple of games working, some natively and some with Proton. I’m now trying to get Civ 6 working.

I tried running Civ natively … no response.
Tried running Civ with Proton 6.3-8 and got it into the game but it froze seconds after each start
Tried with Proton Experimental and got similar results
Each time I get a pop up (Firaxis crash detector, I think) saying there has been a crash and did I want to submit it or not. I’m not sure if/where I can find logs for this.

All of the above were while running i3 as a WM. I also have XFCE installed so decided to log in to that and try …

Managed to get further in, without crashing, but noticed that the Graphics settings in Civ 6 said my graphics capabilities could not be detected, and displayed it as “Unknown graphics card” (or similar). Still managed to get a game started and played on. This was using DX11 as DX12 still crashed. I’m still getting the Firaxis crash warning, even when I can play the game.

I’m not sure if I should have installed drivers for the onboard graphics or not, or what (if anything) I should be trying next.

Relevant bits of my PC spec are:

  • Gigabyte B550I AORUS PRO AX AM4 Mini-ITX Motherboard
  • AMD Ryzen 7 PRO 5750GE 3.2GHz 8C/16T 35W AM4 APU with Radeon Graphics 8
  • Corsair Vengeance LPX 64GB (2x32GB) DDR4 3200MHz Memory

Please let me know if I should be providing any other info to allow for help to be provided.

Checking ProtonDB it looks like the native version often has difficulties. Several people have success with with different Proton versions. Maybe try proton-ge-custom-bin if you haven’t yet? You can install it from the AUR to make it easy. Or Lutris sometimes has install scripts associated for people using their platform.

Also, check this thread for getting gaming setup and working. It’s pretty comprehensive.

Thanks for your reply. I haven’t installed proton-ge-custom-bin yet so will look at that. On a more general note, i.e. not specifically related to Civ, is there something I should be doing for APU graphics to install a driver? I couldn’t find anything relating to my specific setup.

I don’t think so. The standard amdgpu driver should work looking at the compatibility page:

Phoronix did a benchmark on the 5700G and that seems to work just fine. Have you tried anything else or is it just Civ?

Also, this was a couple years ago but it may still be useful: