Problem updating/installing packages with yay

Hi! I hope you all are just great.

I’m a newbie here, so my question is… After updating my system, one of the updated packages (Vivaldi Browser) needed in order to work properly a codecs pack called ffmpeg-extra. I’ve already solved that issue using $ yay -Syu vivaldi-codecs-ffmpeg-extra-bin but after the today’s update and when I try to re-install the codecs pack using the same command, I get this result:

Get “h ttps://aur.archlinux.org/rpc.php?arg%5B%5D=pup-git&arg%5B%5D=teamviewer&arg%5B%5D=telegram-desktop-bin&arg%5B%5D=vivaldi&arg%5B%5D=vivaldi-codecs-ffmpeg-extra-bin&type=info&v=5”: dial tcp: lookup aur.archlinux.org: Temporary failure in name resolution

or I also get this result sometimes…

Get “h ttps: //aur.archlinux.org/rpc.php?arg[]=vivaldi-codecs-ffmpeg-extra-bin&type=info&v=5”: dial tcp: i/o timeout

Also, after this update, when the system starts a notification pops up saying this:

"FetchlAnd Check: wget ‘service’ failed."

I’ve been surfing the web with no possitive results at all.

HEEEEEELPPPPPPP Pleaseeeee :pray:

Thanks in advance

first do always sudo pacman -Syu before you do updating arch packaes…

you have also other stuf from aur ? telegram is in the main repo… for teamviewer there was something but i dont know :slight_smile:

Hi! Thanks for answering :+1:t4:

Yes indeed. I am trying to reinstall the codecs for Vivaldi, as well as mailspring and other packages, but that is the first error that the command displays and aborts the process.

I don’t think the link is any good in the AUR package.

Hi. I checked the link and in the root directory, the folder chromium is empty. I truly don’t know why.

I use

vivaldi-ffmpeg-codecs

and I have no problem so can you try this instead? The only difference is your link is pre-compiled but these codecs don’t get updated often and don’t take long to compile anyway.

Hi Rob! I’ve tried, but it is a 754mb data file and my laptop is an old machine. It spent 4 hours procesing the data with no result. That’s why I tried to get the pre-compiled one.

I assumed you installed from the herecura repo (this is from a trusted user from arch), cos that’s what I’ve always done and I guessed it was the only way but maybe not, and I looked today and the codecs are now there in this repo (pretty sure they weren’t when I first installed) so if you add the herecura repo you can get both Vivaldi and the codecs from there.

Simply do the following and you can use pacman to install as usual (remember to run with -Syu to get the available list sync’d).

Add herecura repo to /etc/pacman.conf (directly above [core] is fine) as follows:

    [herecura]
    Server = https://repo.herecura.be/$repo/$arch
1 Like

Hi again Rob! I think the link was in maintenance. This morning I tried and everything worked just perfect. Thanks for your help. I’m gonna mark this post as closed.

1 Like

this is what i would do if i was still using vivaldi… ready packages instead of building this every time source get updated is much more convinient :wink:

2 Likes

with a lot search work, you have also pamac on a repo , but sometimes is helpfull somes mirror sucked :slight_smile:

1 Like