Problem importing PGP key while updating

Dear community and support team…
First of all, please, note I’m new to Linux and this is my second distro after Mint (it was slow and boring on my laptop, thus I came to EndeavourOS with KDE)… Before creating this post I’ve already scanned all the similar problems and tried the solutions from different threads in this forum having no luck unfortunately(((
Today I tried to update my system in the morning as I do every morning and faced a problem of importing some PGP key… I am not a techie. Just a humanitarian. Could, anybody, pls try to help me to solve this problem?

Hello @Lilit , Welcome to EndeavourOS :partying_face: :partying_face:

Now the error showed up there points the issue related to keyrings.

I had found an article which matches to your case.

hello Phoenix! Thank you so much for your immediate response! Let me check it and let you know if that worked or…

1 Like
sudo pacman -Sy archlinux-keyring
sudo pacman -Syu

See also:


@Lilit Welcome to Endeavouros forum . Enjoy your stay :enos_flag:

Welcome to the forum @Lilit :enos_flag: :partying_face::tada::balloon:

I had to add the Ubuntu key server. This works for even on Arch as I had the same issue. So this is one of the first steps I take whenever installing on a new machine.

GPG import key error

  1. Create a .conf file in /home/user/.gnupg with name dirmngr.conf
  2. Add keyserver hkp://
  3. Add standard-resolver
  4. save and close

Note: :80 is for DNS related. If it doesn’t work with 80 then remove and try again by running killall dirmngr in terminal.