Printing Error

Hey guys, I am trying to setup a Canon MG5420 on EndeavourOS, but have a problem.
In localhost:631, it has a “Unable to locate printer (name of printer).local” error.

This used to work in Manjaro sometimes (not flawlessly)

Looks like this would help you:

The comments are probably worth reading:

Stunkymonkey commented on 2020-05-26 09:49

missing dependecies: lib32-popt lib32-libpng12 lib32-libusb-compat lib32-libtiff4

1 Like

Interesting, I tried installing it and when I tried to do a test page by localhost:631, the printer displayed a progress bar then nothing. I tried to use other drivers, but no luck…

Guys, I fixed the problem. Here’s what I did.

First, I found this forum post from a while ago:

And one of the links from there was:

I changed /etc/nsswitch.conf to be what it said, and now everything works perfectly.


Calling it perfect was a stretch,.

During a print, localhost:631 would throw the same error, but if I wait a bit (can be seconds or minutes), the print will work eventually.

I believe this is avahi not being configured correctly, but I’m no expert here, can anyone help me?

It sounds like the method used for my problem should be correct one but…?

Did you add the nofound=return line?

1 Like

Here are the contents of /etc/nsswitch.conf:

# Name Service Switch configuration file.
# See nsswitch.conf(5) for details.

passwd: files systemd
group: files [SUCCESS=merge] systemd
shadow: files

publickey: files

hosts: files mymachines myhostname mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] dns
networks: files

protocols: files
services: files
ethers: files
rpc: files

netgroup: files

Since the printing does work after some random time passes. It leads me to believe this is an Avahi issue.

1 Like

My guess is that you’re right but that it would not work at all without the edited file.

Not sure if I can help you with this :frowning:

1 Like

I solved this issue awhile ago, here’s how I did it.

Install cups-bjnp (in AUR)
Go to localhost:631
Add a printer and use the bjnp connection option
Use the Cups+Gutenprint … Simplified Driver

Personally, I changed the Color Model to CMYK

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.