Printer Woes

I looked on here, as weel as on Manjaro site, but nothing is working.

I tried installing cups, hplip, but nothing worked.

I ran systemctl enable cups.service, but It brought up the option to add printers, but doesn’t pick up my network printer.

Last time I installed EndeavourOS KDE, in Feburary 2022, I never had a problem connecting it…


What is the printer you want to install and set up?

Edit: Cups should already be installed.

Printer is a HP Lazer Jet Pro MFS M130nw. It should already be in the kernel. When I previously was using ArcoLinux, it came right up.

Worked on Mint, too. (My Dad’s computer)

When I went to install cups, it said it wasnt loaded. When I tried to run cups, before the install, it would say that the command isn’t listed…

Edit: I ran everything in that link you provided. Still doesn’t see the network printer.

It is available, as my Dad’s computer (Mint) and my Mom’s iPad can see the printer…

First of all what does the command show.

systemctl status cups.service

Multifunction HP laser printers use hpuld according to the Arch wiki.

After verifying cups is enabled and working you can try installing the package from the AUR.

yay -S hpuld
● cups.service - CUPS Scheduler
Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; preset: disabled)
Active: active (running) since Sun 2022-10-02 22:56:08 CDT; 11h ago
TriggeredBy: ○ cups.path
● cups.socket
Docs: man:cupsd(8)
Main PID: 563916 (cupsd)
Status: “Scheduler is running…”
Tasks: 1 (limit: 76455)
Memory: 30.2M
CPU: 2.508s
CGroup: /system.slice/cups.service
└─563916 /usr/bin/cupsd -l

Oct 02 22:56:08 mind-hx90 systemd[1]: Starting CUPS Scheduler…
Oct 02 22:56:08 mind-hx90 systemd[1]: Started CUPS Scheduler.
Oct 02 23:11:56 mind-hx90 cupsd[563916]: pam_unix(cups:auth): check pass; user unknown
Oct 02 23:11:56 mind-hx90 cupsd[563916]: pam_unix(cups:auth): authentication failure; logname= uid=0 euid=0 tty=cups ruser= rhost=localhost

Please use code tags around the output you posted.

Sorry, I looked at the wrong info. Please disregard my previous post to install hpuld.

Edit: I need to check further.

I already installed it, but it’s not working, anyway…

Just uninstall it.

yay -R hpuld

I’m not sure where this is coming from? Is that part of the output from the cups status command?

Yes it is. I do not understand why it isn’t working as it should.

Last time I installed EndeavourOS back in Feburary, I didn’t have this issue…

So you do have hplip installed?

Yes, hplip is installed. When I run THAT, hp-install, it just brings up a menu of how to connect to it. Doesn’t find anything on my network.

Try this:

systemctl enable --now cups-browsed.service
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/cups-browsed.service.

Did you try adding the printer through cups?



HP Printer (HPLIP) ?