Printer settings not accepted

In the general settings of Plasma, the printer can be configured.
But only in theory, not on my PC.
I need paper-size as “A4” , not as default “letter”.
I changed it about 50 times now, clicked on “Apply” , but when I print something, there is “letter” format configured and I have to change it manually each time.

Is there a way to configure it in the general settings-menu of Plasma, so it will stay as selected ?

Are you setting it here and clicking apply after?

Edit: Okay i read your post again and I’m not sure. It may automatically default back to letter?

Yes, I select “A4” and click on “Apply”, but this doesn’t do anything. Zero effect.
It looks like it has been changed to A4, but when I close and open the settings-menu again, the default is “letter”.

Maybe I should mention the printer-model.
It is an old 'Brother printer-scanner model: brother-dcp165c
There is only 1 AUR-package for this model and I installed it hundreds of times on Arch-based distros.
The scanner-driver is brscan3 and scanning works fine. Printing works fine too - but the default media-size is “letter” and defaults to “letter”, which is my problem here.

Maybe you can set it using cups.


Edit: lpoptions command will show some print options.

Edit2: Read up on the whole page about lpoptions. You can specify print options and also create saved options for the printer. I don’t know that much about how this all works but maybe you can look at some of the information and maybe it helps.

Thank you, ricklinux.
This editing in cups worked.
Now the “A4” stays as it should.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.