Prime-run not working with wine anymore

Hi,
i was using the Rhino7 through wine, starting it with prime-run to make use of the NVIDIA gpu (hybrid laptop). It worked fine until the last update some days ago.

I can still start other applications like glxgears with prime-run, but not wine-apps anymore.

Command I used before was: “prime-run wine /home/XXX/.wine/drive_c/Program\ Files/Rhino\ 7/System/Rhino.exe”

Entering that now the following output starts with:
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 156 (NV-GLX)
Minor opcode of failed request: 43 ()
Serial number of failed request: 152
Current serial number in output stream: 153

Any idea, how to fix this? Thank you.

If I start the Rhino without prime-run, it starts as usual. Even I start it via gamescope it will run and make use of the nvidia-chip.

It’s not just Rhino. It is wine in general. While other applications (blender, glxgears, thunar) all run with prime-run, every app I try to start with the prime-run command will give me the same error.

My machine is a “InfinityBook Pro 14 by Tuxedo”, running endeavourOS, LightDM, i3

Now it works again, when I type the command in terminal. But not, when I try to run it through a .desktop file. I would like to be able to start it from the menu.